MicroSD card not recognized by WyzeCam v3

I have a camera v3 that I bought in Nov 2020 so just two years back. I didn’t use it for a while or didn’t look for past playback. I tried to do that just yesterday but realized that the camera wasn’t recording to the card.

I then tried to format the card in my laptop but that didn’t help. The camera didn’t recognize the sd card. I tried a different card from my working v2 camera and still doesn’t detect the micro-SD card. I then put the v3 card into the v2 and there the older v2 camera recognized it. So I clearly see that the v3 camera is broken and not recognizing the SD card.

I have tried 3 cards. SanDisk regular and Ultra and different sizes 32 GB and 8 GB. Same results. What can I do? It is out of warranty. Can I somehow try to fix? The firmware for v3 cam is latest. Can I potentially open the camera and clean it? I am fairly handy and it might be a good learning experience if there is any hope of recovering.

Any tips appreciated

What firmware are you using? “the latest” means a lot off different things to different people. If you need to play doctor there are some videos on here someplace on how to take the V3 apart and reassemble.

V3 in the operating room for a different operation. :upside_down_face:


Thanks for asking. The firmware is I will look for videos on how to take it apart.

.139 is good. The link I posted above has a video on how to take apart or you can find on you tube.

For some reason I can’t see the YouTube link but will search myself next.

This is the first time I’ve heard of a camera hardware failure that is associated to a microSD card… other than occasionally getting a message that there is no microSD card in the camera.

PROTIP: only purchase and use cards (from any brand) that are labeled as “high endurance”. BONUS: these cards cost approx the same as ordinary cards.

The SanDisk card is/was high endurance and it works on other Wyze camera. I’ve now seen my first hardware failure unless a firmware upgrade borked the card reader?