Bad batch of cameras or quality control issue - No SD card detected

I am wondering if other recent users are having issues. I currently have 5 Wyze cams that work perfectly (purchased all within a month. I just purchased a 6th. This camera worked but would not detect my SD card. It’s the same size (32gb) and brand (Sandisk) I have in the other 5 cameras. I formatted the SD card with the official SD card program and that didn’t work. I took a known good memory card from another camera and put in the new one. Still didn’t work. I put the new memory card in an older camera and it worked fine. It’s not the memory card. I then returned it to Amazon and got another one yesterday. I had the exact same problem, No SD card detected. I again tried all troubleshooting procedures. Nothing worked. Since I have 5 working cameras I know it’s not me. I am hoping the 3rd replacement camera works. Either there was a bad batch of cameras or there is a quality control issue that I am hoping will be addressed. These are great cameras but it’s hard to recommend these with what I have been experiencing.

@None recently discovered a missing resistor:



And others…

I will add, someone on Reddit has a cam that won’t recognize the SD card but it isn’t specifically this issue of the missing resistor on the circuit card. So, there could be other failure modes out there.

As to “quality control”, since Wyze doesn’t produce these cameras, I sure hope they are holding the supplier accountable for all the cameras they have to replace.


Thanks for these responses. I am hoping the 3rd camera comes from a different batch. I agree Wyze needs to hold their supplier accountable as it tarnishes the reputation of an otherwise great product.

My replacement worked 100%. If you have a moment, you can reply to one of those posts (not sure exactly whcih one) and tell them what your MAC address is. It might help them corral others.

Unfortunately I didn’t take pics of the MAC address. If I get another defective one I will. I am hoping the 3rd one works.