Beta WCO and Base Firmware Bricks Devices


Please stop the WCO and Base Firmware deployments! It’s bricked both of my WCO and bases.

I upgraded yesterday without a problem.

(2) WCOs w/4 cameras each at two separate locations.

Base stations are connected via ethernet

I’m not seeing a update available for the base station, but my WCOs updated with no issues

I updated to cam firmware and base firmware without a problem also.

5 WCO cams over 2 locations.

3 base stations… 1 on Ethernet, 2 on WiFi.

Per directions, updated cams 1st, then base stations.

I updated my camera and it auto-updated my base station. This was a bit confusing at first because I saw it in the FW updates area with the camera.

All updated fine

yeah, I just remembered mine are beta units and are stuck at a lower firmware level

I just did the upgrade today and I did have a slight abnormality.

I went to the firmware update section of the account tab and clicked on “update all”

It said it was updating the WCO. I waited a LONG time, and it just stayed that way. I went out and back in and it still said it was updating, but it frozen on that status of saying it’s updating. It might have been over an hour. It would not change even going out and back in.

Finally I decided to check the device from the home tab. It still had 69% battery, so that seemed fine. I selected the WCO, and it told me it had a pending update, and took me to the screen to approve to update the firmware individually. I told it go ahead, and it did. Then I went back to the account tab section and clicked update all again to update the base station and this time it worked to do it from there. Base station upgraded smoothly.

I checked to see if the WCO was still working, and it is. Everything seems good.
I still felt I should confirm there was a slightly weird anomaly for me with doing this update though…but the end result worked out okay.


Update as of 21:30 eastern. I think I was extremely unlucky with whatever event that you’re having today.
I’m going to not use the use the Android Beta App for anymore firmware upgrades and adding new cameras. Sunday was a fiasco adding the Wyze Car.

1 WCO at is definitely bricked.
1 Base at is online but reporting it as offline in the app. I can see DNS queries and traffic to Wyze Servers, so I know that it’s online. But your API doesn’t seem to thing so.
Both are remote and I’ll reset on Thursday. Luckily I have a Wyze Cam V3 inside a few feet above the WCO.

1 WCO is online now and still stuck at “Updating” for 8+ Hours. It’s gone from ~63% to 48% in that time. I’ll plug in a Microusb cable in the morning.
1 Base is at despite the WCO still “Updating”.

1 Like

Maybe try using a hard reset to factory settings and try setting them up again. If that doesn’t work, try using an SD card to flash the firmware back to an earlier working version too and see if it will come back to working status for you. I have had to do both of the above in the past for different things.

I experienced the same anomaly. I tried several times updating all from the firmware tab of the account menu and it failed every time after about an hour. So after about 6hrs of trying “Update All”, I opened the live stream for each cam, where I received a prompt to update, and this worked successfully and took about 1min. Base stations prompted to update when opening settings menu.

Is there an info release on this update describing what has changed?


Not much, bug fix

1 Like

Ah, thanks for sharing! I tried to get a support ticket going on the WCO Battery Usage Summary the other day - they sent me a canned response almost immediately and the update came out the same day.

I can dig it!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.