WCO (Wyze Cam Outdoor) - Won't Update Firmware

I can’t remember, but I think it updated when I first set it up (or perhaps that was the base station).

Currently at v4.17.0.128, wants to upgrade to v4.17.0.159 (was v4.17.0.158 a couple days ago).

It always fails. Tried everything I can think of and read through some FAQs. Turn WCO off, then on, rebooted base, placed WCO very close to base. Plugged WCO into laptop via it’s USB cable and while charging, tried that. Tried at 100% battery. EDIT: as posted below: Base and Wyze app were always updated first (current) before attempting WCO update

It simply fails every time. All my other Wyze cams will update their firmware. This is the only WCO I own. The base station updates fine.

Anyone else having issues updating its firmware

If you haven’t updated the base station update that first then try updating the camera.
If that doesn’t work:
You may need to try removing(deleting) the camera from your Wyze account/app. This is similar to a factory reset. Then you can reinstall/add the camera to the base and try to update the firmware.

Yes, I should have posted that above… I have removed the WCO from my account and re-added it, a few times… same outcome.

I have now uninstalled the Wyze App from my phone (Android - S20+) and trying again. EDIT: Got the same "Oops, we’re sorry blah blah failed’ message!

Base and Wyze app were always updated first (current) before attempting WCO update. Of course, there was another base update the other day.

Is your camera fully charged?

yes, and posted this in 1st post

does anyone know the shipping f/w version of these early adopter WCO’s?

Is it v4.17.0.128 or earlier?

I know this might sound like a step in the wrong direction but, try deleting the base station and reinstalling it. The camera connects to the base so that could be the issue.
If that doesn’t fix it then something must be faulty.

1 Like

Hi @DroidST The WCO can only update via the WiFi generated from the base. It is a separate sub-net from the one the base is plugged into.
Your phone has to be on the same WiFi sub-net as the base physically connected.
If you have 2ea WOC base units, unplug the one you are not using for the update.
Hope this helps. . .

1 Like

Do you mean I have to connect my phone to the Base’s WiFi? I do see the SSID here, but don’t know its password.

Does this have something to do with Travel Mode?

Right now, the base is hardwired connected (Ethernet) to my WiFi/Router and my phone is connected to my Router’s WiFi.

1 Like

That is correct, your phone and base should be on the same network (not the WOC’s network).
Your phone can be on the 5GHz network and the base can be on a 2.4GHz as long as they are in the same subnet. e.g. from the same router. Hope I’m not confusing the reply here.

1 Like

This WCO’s base here only operates on 2.4GHz, of course the WCO connects to that.

The base connects to my network’s Main Router via Ethernet (hardwired) and my phone connects to my network’s main Router @ 5GHz.

I have no problem with all functionality of the WCO via the Wyze app on my phone and I can see that WCO is on a different Subnet (WCO IP viewed in the App) vs my phone. The only thing that doesn’t work is the firmware update. I can watch the WCO live fine, do two way audio etc.

If I am supposed to connect my phone to the base’s 2.4GHz, I don’t see that information here on Wyze’s website or in the WCO box. I can attempt to connect but don’t know the base’s WiFi password for its SSID (which is on 2.4GHz).

I guess I’ll ask again, am I supposed to connect to the base’s own 2.4GHz WiFi to do the firmware update?

No, don’t attempt to connect to the private network between the base and the camera.
Your phone needs to connect to the same network as the Main Router via WiFi. If I understand you correctly you are doing this already. e.g .You have all functionality of the WCO via the Wyze app.

If everything is working except the firmware update then I might say the TCP port was being blocked at the router. You have other Wyze cams that have completed a FW update so this would not be the issue here.

Remove the uSD card from the camera? OK, you’ve got me stumped. Maybe @Brlepage has a suggestion.

1 Like

Yes - and, all other Wyze cams (not WCO’s) will update their firmware without issue… I only have one WCO.

I’m running Asus Routers here with Merlin’s firmware… I’m starting to think I may have something blocked in my Main Router… I’ll dig around. I don’t see any troubleshooting info on Wyze’s site in regards to failed firmware updates on the WCO.

Does the WCO (and the Base) come with SD cards inserted already? I haven’t added them or even checked those slots.

No, the WOC nor the base come with uSD cards.
You might try rebooting the router & phone.
Most ports are standard but regarding firmware there are:
TCP: 8605 Upgrade package download Firmware Upgrades
TCP: 10002 LAN firmware upgrade Firmware Upgrades

Here is a list:

That’s one thing I tried today, I power cycled the base… same outcome - fail

The base will update it’s firmware via the app without issue, I believe I’ve updated the base two times. Just the WCO connected to that base is having issues with updates.

I would assume that those ports are common for all Wyze cams, and the others are updating. I will take a look closer in my Main Router.

1 Like

I agree, the other Wyze are all updating fine. Just the WOC is misbehaving.
Its probably something simple we’re overlooking.
My WOC updated when it was first connected.

I think my WCO updated it’s firmware upon initial setup but I can’t remember now. It’s on .128 and I’m not sure what the shipping version was.

I got it via Early Access (July) and activated it on 8/14

What version is your WCO on?

I noticed the WCO led does blink once when I attempt a f/w update.
EDIT: LED goes likes this… I connect to camera, blue LED is steady. After the f/w update process starts after 5-10 seconds, the blue LED goes off for a second, then a quick Yellow color for that LED and back to Blue and steady.

Is that your WCO LED behavior during the update?

1 Like

That light sequence sounds about right. Steady blue is conected and working. I had ver. on both the base and WOC. After that I sent it back due to oher problems.

Just received Test RE: New FW for WOC. I only see the version you are looking at dtd 9/9/2020: Base: WOC:

Factory Reset - Hold the setup switch, continue after the ready to connect prompt for another 15 or so seconds , then another ready to connect prompt will announce.
Go through the setup again.

I looked at that a few days ago though you can remove it from the app then re-add it (I think the settings remain though when I did that):

For security reasons, you cannot factory reset it.

Unlike other Wyze Cam devices, the Wyze Cam Outdoor cannot be hard reset. In the event that the camera is stolen, it cannot be reset and disconnected from your Wyze Base Station or your account.

Instead, it can be power-cycled by flipping the switch on the back of the device. Turning it off and on again won’t disconnect it from your account or reset it to the original settings, but can help with troubleshooting.