Background/Ignore settings for Smart detection

I love the Smart Detection features, but I have had to turn off Package Detection because both my Video Doorbell and Cam v3 keep detecting shelves/doormats in its view as packages whenever there’s a slight lighting change or movement. Not only does this send useless notifications, but for my Doorbell it wastes battery power.

I think it would be useful to allow users to set a “background image” where the camera ignores anything that always stays in the camera’s view. Maybe use some sort of motion tagging/multiple images for different times of day/lighting changes to make it more accurate. This would help with my package issues plus other times where I’m sure people have gotten People or Car notifications with static background objects.

Welcome to the user forum community @Zigmatism! Don’t forget to Vote at the top.

This has been a Wyze user complaint for some time now. The cams are dependant on motion for recording activation but the AI is NOT dependant on motion for tagging. Also, the AI ignores detection zones, those are only used for motion activations.

Parked cars are my Kryptonite! But I also get the package alerts for the doormats or the downspout runoff ramps.

Wyze has said they are moving toward moving object AI detection to fix this, but the outlook doesn’t look good for the near term. This is their post from 4\11\22. So, your #wishlist request should get elevated to a #roadmap list item soon.


Thank you! This is a pretty recent post from them, so hopefully something will come of it relatively soon.


Well… We can hope. But the tone I interpreted was that they have to reinvent the wheel and it is going to take time…


I mentioned a temporary, obvious workaround in the meantime, at least for packages. Turn off package alerts and use deliveryperson alerts instead…

Doesn’t work, unfortunately. Person detection grabs people from a distance (our door looks out onto a sidewalk). Another thing I wish Detection Settings worked for.

1 Like

Okay but… The motion sensing DOES respect the zone, so if you zone the doorstep only then you should only get events when (a) there is doorstep motion and (b) the Wyze AI then identifies a human in the frame. This works well for me even on the Lite tier.

For some reason, person detection still procs outside the detection zone. I wonder if they added “fuzzy” detection to the edges? But shrinking the zone would make it useless for what I need.

1 Like

The reason AI tagged objects are outside the detection zone is because there was something else inside the detection zone that set off the Detection Recording.

If the cam detects even the slightest change in pixelation lighting inside the detection zone: sunbeams on the pavement, bugs, birds, grass swaying, leaves rustling, branches moving, etc.; It will activate recording. Once recording has started, the AI looks at the entire frame. It does not respect the detection zone and it identifies any object, moving or not. It is possible to have a person, pet, vehicle, and package tag all in the same clip, all outside the detection zone, stationary or moving, if the cam was set off by a fly landing on the lense.

So, every time you get a new alert for that same package, even if the package was outside the detection zone, it was caused by some perceived motion inside the detection zone.

Two ways to deal with this: 1.) Constrain the detection zone. Can be too limiting to catch the real motion you want to see. 2.) Dial back the Detection Sensitivity to a comfortable level where the small movement won’t trigger it but larger objects will. That way the leaves and grass and such won’t trigger an event.

I’m trying every workaround I can, though it doesn’t help much. My main issue is the front doorbell. It currently looks out onto my front steps, but also my street, including a sidewalk. I have the motion detection set to only respond to literally the lowest row (my steps and a bit of the yard on either side), but I still get notifications about either a package (my doormat) or a person (someone on the sidewalk way out of the detection zone).

I don’t know how hard it would be to just only record/notify of an AI event if it’s detected inside the Detection Zone. I feel like it can’t be particularly complicated, since they already have the detected motion and the zone. But I will admit that I am not a programmer. It’s just frustrating and something I didn’t expect to have to deal with for a doorbell camera.

1 Like

I am not sure why your setup is proving difficult while my similar one is working well.

Meanwhile I checked and TinyCam’s detection zone settings (which I am not using much) are supposed to work as you wish - only doing AI detection for the part of the frame defined as a detection zone.

It sounds like you have the Detection Zone dialed in pretty tight.

What I had to do, once I had my DZ where I wanted it was:

  1. Since Motion Tracking (green box) isn’t available on the DBC (#wishlist topic here: Wyze Doorbell Motion Tagging) I watched every repeated, mistagged, or errant video to see what, within the detection zone, was motion triggering the cam in the first place.

  2. If I saw a specific area that was constantly moving from the edges (bushes,grass etc.) I added it to the exclusion zone.

  3. Then I started dialing back the Detection Sensitivity by 5% each time until it quieted down. Once there, I went back up 1% at a time until I got a bad AI tag within my excluded area. Then back down 1% at a time until it stopped. That is where I am now and it rarely throws an errant AI tag unless the weather is particularly nasty.

A PIA for sure, and it took like a week, but it did eventually quiet down.

This would be a really nice option to have in the settings:

:negative_squared_cross_mark: Smart AI Detection ONLY in Detection Zone
:white_large_square: Smart AI Detection FULL frame

Perhaps an additional #wishlist item.


Thanks! I’ll give your advice a try. And yes, this would be a great option to have.

1 Like