Anyone having issues with Wyze/ Alexa today? Cams are up via Andoid Wyze app, But none of my 4 V3 are responding on Echo Show 5

4 Wyze v3 cameras via amazon echo show 5 with alexa voice.Anyone having issues with Alexa routines for Wyze Cameras or manually viewing them by asking "Show “Camera Name”?
I disabled wyze skill and reenabled, relinked on Wyze website.

I asked Alexa to “show cameras” ithe All Cameras view came up but then said;
“having trouble accessing smart home prod dashboard skill right now” I also can’t view wyze cameras manually via the alexa app on android under camera device section. All are there, None will load.

Not sure what the issue is. I did recently update on all four. Please fix the integration on the skill please.


Yes, my V3 (latest production firmware), stopped working during the night with Alexa. No live view in the Android Alexa app and doesn’t show up on the Echo Show or Fire TV.

V3Pro working fine.



Last night Alexa became unhinged with the Wyze Skill and required me to relink the Wyze Skill. First time that has happened to me since I enabled it years ago.

There were a couple of routines that were a bit late, a couple others just didn’t fire the action to a wize plug. Others did. Going to keep an eye on it when I get home.

yes did that but still no response

1 Like

Light bulb not working also.

Had to wait to get home to fiddle with it. I rarely stream w\ Alexa. Never on my phone, only on the FireTV Stick.

All V3 are reporting as “Unavailable”, V3Pro tries to load but fails. VDBv1, PanV1, PanV3, OGS, and OG-T all load and stream. V3, PanV3, and V3Pro are all on Beta Firmware.

V3 Person Detection announcements on Alexa are not working.

Plugs, bulbs, thermostat, and vacuum are all responsive by voice command, routine, and Alexa UI command.

I just tested my array of wyze cams using the “Smart Home“ function on my fire cube and was able to launch and stream my V3s as well as all the other supported cams.

I also tested via voice command and all pulled up as well.

1 Like

Same here. None of my fixed (non-pan) v3 cams are working with Echo Show or Fire Tv anymore. I have relinked my skill twice.

All my other cams (v2, v3 Pan, OG Telephoto) are working fine.

This is clearly something that Wyze should be looking into, but when I chatted with them earlier today they played dumb.

I can’t say for sure, but they may have stopped working after the latest firmware update. All my v3 fixed cams are on firmware


Same issue. Works on my android app and Microsoft Edge web view but says there’s a problem on my 2 Echo Show. All 4 of my V3 cams don’t work on the Show. Started happening a day or so ago.

I did notice that the Amazon Echo Show had an update in the last day or so, maybe the update messed something up?

Been on that firmware with the V3 at least a couple of weeks, the problem only started the other night. It has been working fine with Alexa for the last couple of months.

As far as I can tell there have been no updates that have happened recently (last few days), to the Alexa or Wyze apps or the V3.

1 Like

Me also. My 3 V3 stopped working on my show 8. My V2 and my PanCam 3 are still working. Tried everything.

1 Like

Same issue. My V3 will not display on any Echo Show devices. My V2 cams work fine. Started in the last couple of days.

Alexa had a major outage on Sunday. Since then I cannnot view my cameras on my Show 8. The Wyze App is fine, my Google Home works as well. Nothing I try in the Alexa App seems to fix the issue nor does rebooting the camera or the Echo device. This is definitely a problem.

mine too but that is NOT the issue,
I just setup a brand new wyze cam v3, It has cam plus trial and running firmware
4.368.15 and alexa gave me the same exact response when I asked to show it.

They work with Google Home app on my end too, This is definite Alexa issue or Wyze/Alexa skill issue
All 4 cameras I was able to Stream cameras on chromecast.

Same here, I tried unlinking/relinking the skill to no avail.

Curious, Please advise

Will Google do routines like Alexa did? Where if a person is detected, it will automatically bring up the wyze camera?

My V3 just updated Firmware again to for some reason, but this had zero effect on the Alexa integration issue.

Finally Got amazon to admit something wasn’t working on their end.


For anyone experiencing this issue. Please note that Wyze is very much aware of the issue and is currently working on a fix:


Nice! I’ve been there once… talk about a rough support experience. Alexa support is not nearly as easy as Amazon returns.

1 Like