Annoying demands for location

Since updating to the Wyze app v2.18.43 on my iPad it demands I turn on location in settings so it can scan wifi networks when in “travel mode”. I tell it “no thanks” and can view my cameras normaly.
The next time I use the app it demands location again. It would be nice if it would remember my choice.
How do I kill this “feature”?


I too would like to know how to disable this entirely, It is getting quite annoying.



And I don’t even have a cam that supports travel mode.

1 Like

This seems like a bug.
Please submit a log to help Wyze developers and engineers fix this.

1 Like

I just looked at my iPhone and I set mine to Never in the settings area for the app and was not prompted when I started the app nor when I viewed the WCO’s which allows for travel mode.

So might be as simple as select while using app and the switching it back to Never. You might be able to go to settings and select Never, which is the first option in the list for location on the app.


@spacepiggy Go to iOS Settings > Privacy and select the “Never” option as @spamoni4 mentioned above.



I just submitted the log thru the Wyze app. While typing the report the dang nag popped up again, so I grabbed a screenshot and sent that to them too.

1 Like

I have repeatedly visited the setting page for iOS and selected Never. Doesn’t work. I tried selecting Always, closed, reopened to select Never. Doesn’t work.
This is very annoying. The Wyze app on my Android phone does NOT do this.

I’m having the same issue on my iPhone and it is infuriating.

1 Like

Apple requires location access because Apple says people can determine your location my nearby networks. So the app has to ask if you will allow location access if they need to find your home network. However, I also believe it is a bug to ask you that more than once, so keep reporting anything else via logs.

1 Like

Nope. Doesn’t work. Still asking me to turn on location settings. Because I really want to travel with my doorbell.

And it spams me.

Created an account just to chime in here and say I’m seeing the same thing. iOS 14.4.2, Wyze v3
I’ve only every had location disabled for the Wyze app. I tried switching it to “Ask Next Time”, killed the app and reopened it, and then told it no again. Hoped that maybe it needed to be more explicit and possibly find a work around, but no luck.

I’d be curious to know the distribution of Android and iOS app users.

Google doesn’t have the same focus on privacy and security as Apple and I suspect the pain threshold for Android users is higher.

I read something today from Winston Security about how they develop for iOS first because if they can make things work there, any other platform is cake.

The mobile app has been another major area of focus. Unlike past efforts, we decided this time to focus primarily on Apple/iOS.

Why? Because iOS has consistently been the most difficult to code for. Apple’s designers have a knack for creating APIs that prevent any useful functionality from being added to their devices, particularly at the networking layer. So our thinking is that if we can support iOS, then we can (eventually) support anything.

My assumption is Wyze goes the easy route first.

Also created an account just to say this is the most annoying thing ever. Every other time I open this app now it asks me:
‘turn on your location to let Wyze scan nearby Wi-Fi networks while in travel mode’

PLEASE fix this bug before I throw this camera out the window and buy one from a manufacturer that doesn’t have pop-ups every time you start the app. There must be some way to stop this notification. This camera is in a house and is not going to travel. Raising a child is hard enough without this added annoyance.

1 Like

I MAY have found a solution, no nags for past 12 hours:

On the iPad open Settings (should be similar on iPhone), scroll down on the left panel to find Wyze, select it and on the right panel I turned off Local Network. In fact all Wyze access items are now turned off. The app still functions to allow viewing my cameras. I assumed Local Network was needed just to work, but apparently not.

The nagging didn’t start until both iPadOS and Wyze app were updated. Possibly one or the other broke something?


Same issue here. I will try the local network disable trick.

YAY! This worked for me as well. Thank you!
Now I’d like to know what might not work with that setting disabled.

1 Like

There is a lot about this on the Net.

I had an issue where I could not print to a printer on my network unless I had that selected. I believe it simply stops the searching of your local network. There were some other basic issues like a Baby monitor app we used when the Grandkids are here, it would not work until I turned this back on.

I found this explanation on the net.
Local network privacy provides added transparency when apps connect to devices on a person’s home network . If your app interacts with devices using Bonjour or other local networking protocols, you must add support for local network privacy permissions in iOS 14.

Also an issue. Please fix

Same here just started after update. They need to fix this crap. i dont need to share my location.