Android Users: Does the Filter View works alright for you?

I have an Iphone and an Android and it works very well in Iphone, but in Android when I open the Events view, and try to filter by Person, Vehicle, Pet, it doesn’t work at all, the filter does not get highlighted, neither it is applied.
It is like this both for the quick button “Person” on the Events View and for the “Filters View” where you select different filters.
It neither works on any of those views, so I can’t filter events on Android.

Xiaomi Redmi 12 pro 5g.

I know it has a Battery Optimizer thing, I disabled it long ago for the Wyze App, I still have issues.

On your Android Phone, can you provide what App Version you are running.

I have seen that in the past, but if I click on the Events tab and wait for a little, it seems to kick in. But I have not experienced it recently.

Hello Spamoni4,


I just tried tapping on “Person” button on Events tab, waited a few seconds until screen goes off, but nothing happens. I even tried keeping the screen active by tapping a blank area so I can wait a longer period of time, but nothing happens for me. Probably some Xiaomi stuff.

UPDATE: It has been reported that this issue has been resolved in App Update

This is an issue that has been reported in several threads and the Fix It Friday thread. Wyze has confirmed the issue and stated it is being worked on.

It began with release 2.44 and continues into 2.45 affecting isolated users. To date, I have not seen a successful fix or workaround in those app versions. The only successful path I have read is a reversion to App version 2.43 which is detailed in the threads linked.

See these threads for posts from users affected: