Am I wrong or should I argue with support to keep my still active Home Monitoring rate?

Looking for advice, since I’m not sure if I’m right or wrong on this one.

I’ve had Home Monitoring since very early on and it had a locked in promotional rate of just under $60 per year, billed semiannually. I’ve never let it lapse and it’s renewed multiple times at that rate without issue.

My next 6-month renewal date is coming up on Jan 5th. However, for some reason, (maybe because I had to change my email address about a month ago), even though my HM service transferred fine, works just fine, and shows as current and valid on my account correctly, shows the next renewal date of 1/5/24 and the price of $29.94.

But it also says:
"Next payment due 1/5/2024 But we don’t have your billing info. Please add your billing info at Home Monitoring & Security Services - Wyze Services

Clicking that link directly in the app leads to a 404 page, which is a problem in itself.

Going to my account online, I verified that I have two valid forms of payment that show on my account. It also shows the same info as in the app about my current valid HM service, my correct price, and needing payment info.

I called Wyze CS which after a long hold to speak with someone, couldn’t do anything with services, so they had someone from services email me which they did. The problem is that their solution is that in order to update my payment method (which two of them already show on my account), I need to repurchase the subscription at the current full price of $99 per year.

My thought is that I have a current valid subscription that I’ve had for a long time, haven’t let lapse, and have been renewing, so I should be able to continue to renew without interruption at my current and active rate.

Any suggestions, or am I completely off base thinking as long as I don’t miss a payment, my rate should continue?

3 Likes

Yeah, let me bring this to the attention of the head of subscriptions @WyzeMatt because I am sure he would like to know about this issue.

2 Likes

Oh thank you!
I haven’t replied to the response email from support yet, so I’ll wait. I didn’t want to waste their time if I was off base.

Ray

1 Like

You’re not off-base. If you want to know more details I can explain a little more. I think things like this are an occasional unexpected glitch based on the way Wyze’s initial database was set up. From what I gather/understand, when Wyze first started, their database was set up to where the email address was listed in the backend as what’s called “the primary key” in the database. This caused some issues in the past where people could never switch their email address because that was the “account number” and you can’t change the primary key (account number) or it can cause chaos. The best practice is to have a totally separate, unique account number as the primary key for each account and have the email address be a totally separate field that can be changed at any time without disrupting anything. Basically, it required canceling an account and starting a new one and setting everything up from scratch again. The bigger Wyze got and longer time went on, the bigger problem it became that people couldn’t change their email address. This particularly became an issue as it related to subscriptions and things like the Wyze Cam Outdoors and Base Station that were tied to a specific account. You couldn’t close and open a new account without potentially risking causing loss of subscription money or bricking WCO’s/Base-stations. So Wyze created a “fix” or a workaround to simplify Email address changes, and now it works fairly seamlessly for 99% of users, but there are still some weird circumstances like this where I believe what is happening is that because you had a grandfathered package that is no longer available, it won’t automatically transfer over correctly because of the foundational database structure issues (I believe they weren’t fully converted since I still rarely see weird issues like this). So in my somewhat educated opinion on the matter, I would argue that this isn’t your fault in any way, and is simply leftover fallout from the way their database foundation was structured less than optimally.

Therefore, I am hoping @WyzeMatt will take a look at this for you, agree that it’s not your fault, that you didn’t choose to cancel or change your HMS subscription, and that you deserve to keep your grandfathered plan rate and shouldn’t be “punished” just for changing your email address but not intending to change anything else. It’s a glitch I’ve seen on rare occasions, but I’m pretty confident it’s a backend glitch and I’m hoping WyzeMatt can find a way to resolve it for you, because I pretty much guarantee that it is above the access of anything that support can do for you.

Nonetheless, let’s give him a chance to look into it. I know you haven’t replied to your support ticket yet, and maybe Matt might ask you to do that still, but will you at least post the support ticket number for us in here?

Also, will you submit an app log of whichever you think might be the most relevant and post that log number in here?

Also, appreciate your patience and the way you handled this with grace, etc. You’ve always been a reasonable guy @raym64 and very helpful. I’ll follow up and make sure Matt gets some eyes on this. I know that as the main subscription guy he would like to be well aware of this glitch because he wants people to have a good experience with his subscriptions and this will be something really useful for him to look into better.

Edit: To be fair, my above hypothesis, is just a hypothesis, but I have seen email address changes through Wyze cause similar chaos before (particularly with subscriptions), so I believe this is a likely cause because I do know that the email addresses USED TO BE the primary key that everything else was tied to, and I see it still doing weird things on rare occasions. So, I am not saying this conclusively, but I feel it is a fairly educated guess based on my database education. :wink:

2 Likes

@WyzeRyan I would like for you to take a look at this but I personally agree we should give the grandfathered rate. Our internal motto is that if you will stick with us, we will bend over backwards for you. I hope we can do that in this case.

For everyone here, @WyzeRyan is the inventor of the Wyze Home Monitoring and one of the most brilliant individuals on the services team. Truly an extraordinary individual.

7 Likes

Hello @raym64 , thanks for sharing your case.

We will and we should keep your subscription at your original rate. Please DM me your current and previous user ID (email) so that I can step in.

5 Likes

Thanks @WyzeRyan, I will DM the email addresses in just a minute. Also, if needed, the support ticket number is 3544330

Thanks for your helpful reply!

4 Likes

Thanks for the very thorough reply! You’re always a big help.

Ray

3 Likes

Thank you very much @WyzeMatt and @WyzeRyan !

Ryan is on it in DM’s and I really appreciate the support.

4 Likes

What a boss.

3 Likes

It’s been a while and my renewal day has passed, so I thought I should update on the situation.

After DMs with @WyzeRyan, he assured me that I would keep my reduced rate and that my renewal would happen on schedule with my PayPal account which is one of the two payment forms on my Wyze account. He also had me submit a log and screenshot of what I was seeing in my app, and he would look into the problem.

On January 5th, which was my renewal date, the automatic renewal did in fact go through fine for six months with autorenewal scheduled again for July.

That of course was the important part and I kept my subscription without a break in service or price increase. So Yay, thanks @WyzeRyan !

As far as the app and my monitoring account, the problem is still there telling me I have no payment method, but since it worked, that’s what counts. This is actually what I see in the app and the circled link goes to a dead page when clicked:

@WyzeMatt and @WyzeRyan I am running into a similar issue where I paid an annual rate of $60, but was somehow switched to $100. Last year support was able to refund me the extra $40, and they told me that I would be only charged $60 from then on. However, I just got charged $100 again. Now I am being told that I am not allowed to have the original rate by my latest interaction with support. (The support ticket is 3799913)

Apologies for commenting on an old thread if that is frowned upon, but is this something you can help with?

1 Like

@taylorb101 If you don’t get a response on this within the next few days, please tag me and I’ll escalate this to someone to look into for you. :+1:

I think your tags and your support ticket should be sufficient as it is though. But just in case, feel free to bring my attention back to this in a few days if you still haven’t heard anything,