Alexa won’t show live feeds

I installed it about a week ago. I’ve tried renaming it as well and initiated a discovery in Alexa. No fixing the issue. Obviously, Wyze knows this is an issue and has refused or is too incompetent to fix it.

1 Like

Similar to the Alexa issue making my new V3s useless for my purposes.

(As with you, the renaming doesn’t do squat to help.)

Please stop spreading this. It’s misinformation, and clearly hasn’t been working for most users. Wyze should have fixed it when this solution still worked, because we shouldn’t NEED TO do that to get their product working as advertised.

Even more now, that solution literally isn’t working at all. Wyze needs to fix it, and you need to stop pretending it’s fixed.

1 Like

Yes, renaming did not work for me either. At this point, I can still use the app, which works perfectly fine. But it would be nice to use it on the Alexa Show while doing stuff in the kitchen. This clearly has been going on for a while for a lot of people.

1 Like

I am not pretending anything is fixed I am gathering details and suggested a step that has worked for me in the past that the OP did not put in their original list of steps that they tried.

I am also not experiencing this issue currently with my V3 Wyze cameras that have been deployed for awhile now. Hence my ask as to when they installed.

With additional information and a Wyze support ticket number I can also assist in escalation for visibility.

If you have one please share.


My V2s, V3’s, and V3 Pros are all streaming to my Alexa show 8 okay.

I just tested streaming my Pan V3 to my Amazon Alexa Show 8, and it wouldn’t work, it kept pulling up youtube or search results, but I had the camera listed with a fairly complicated name in this format: wordletternumberletternumberemoji --yes, including an emoji in the camera name-- and thought that might be part of my problem, so I tried this suggestion:

And I renamed it simply to “Pan V3” in the Wyze App. Then I checked Alexa, and Alexa still had the old name showing, so it still wasn’t working right since Alexa hadn’t refreshed yet… I tried a few things to Alexa to refresh and update to the new camera name, and it finally did. Once it updated in Alexa, I tried again and the live stream is now streaming on my Amazon Alexa Show 8. So I can confirm that the Pan V3 is compatible with streaming to Alexa Show devices, and that the above suggestion of refreshing the name did resolve my streaming issue.

I should mention that I am running the new Beta Firmware on it, so it’s possible that makes a difference? IDK, but if it is the Beta Firmware making a difference, hopefully that gets released to everyone soon. For anyone who doesn’t want to wait and is interested in giving it a try and see if that helps fix your issue, I am talking about this one:

I don’t think it should need the beta firmware though.

If any of the above doesn’t resolve it for someone else, I would certainly consider contacting support:

Edit/Update: I let it stream for over a half hour before I decided that was long enough to confirm it’s working as I would expect. I hope others having this issue can get it resolved.


I just tested Alexa on the following successfully:

  • Cam V2
  • Cam V3
  • Cam V3 pro
  • Video Doorbell Pro
  • Pan V3
  • OG-S
  • OG-T
  • Video Doorbell v1 (Streams the correct way)

I asked Alexa to show the aforementioned devices and they cam up without hesitation. I will say that the V3 Pro was the fastest to load.

In the past, when I had issues, I had to disable the Wyze Skill and then Enable it again. There are issues with Alexa where it will Cache a name and then become confused. Disabling and enabling the skill seems to work. When that has not worked, the renaming of the device worked as well. Note: When Password changing is done, your devices may need to be linked back to Alexa. This is a known thing.

@R.Good is correct in that Alexa has a hard time with devices and at times will take a period of time for them to be fully functional. Renaming the device seems to give it the boost needed.

As @carverofchoice indicated, if the problem persists, contact Wyze and obtain a ticket number.

There are other routine steps individuals can try to see if they can get it to work:

  • Unplug the Alexa Device, wait for about 5 minutes and then plug it back in. Then try the Streaming again

  • Start on the App and Device Side and clear the cache from within the app, located under Account > App Settings.

  • You can Log out of the App, just make sure you have your password and 2FA to log back in. Restart your Tablet or phone, then log back into the app.

As indicated above, when passwords are changed and potentially other items occur, you may need to relink your Wyze Account. When relinking, I would perform the steps above to clear everything first, then go to Alexa and disable the Wyze Skill. I would then shut Alexa down on the device you are using to ensure its cache is cleared. Then Start the Alexa App and Activate the Skill again.

For those having issues, It would really help if you could provide some additional information:

  • Camera Model being used
  • Camera Firmware Version
  • Camera Plugin Version
  • Name of the Camera - Some Characters may not be permitted within Alexa
  • Generate a device Log by live streaming the Device, going to the Gear (top right), go to Wyze Support, the Submit a log.
  • Post the information as it helps Wyze to see what is happening and also provides them with something to look at.

There are a few of us who can also escalate if needed. But, in order to escalate, we would need the ticket number from when you called in.

Remember, this is a community member to community member forum. Wyze will, and does, check in occasionally.


I’ve tried these solutions as well, to no avail. I will try a formal ticket

1 Like

out of curiosity, are you asking for Alexa to show a camera, or are you trying to do it from the touch screen.

Alexa has an issue when using the touch screen approach

Good question, I’m using the verbal command “Alexa, show me ______”. It switches to a loading screen for a moment, then fails. The V1 and V2 cams all work fine, and I’ve tried all the renaming restarting mess and gotten nowhere.


Yea, if you could contact Wyze, get a ticket number for this. I would be glad to escalate for you

When you go to Alexa on your Phone or Tablet. Go to Devices on the bottom of the screen, scroll the device list to Cams and tap on that.

What happens when you tap on the camera in question?

My Cam V3 will show a live feed.

One last question, sorry to be so sporadic but they pop in my head at different times :slight_smile: , do you have Cam Plus, Cam Plus Lite, or anything associated to the camera you are trying to stream? I have Cam Plus on all of my cameras, but can change them to test as well.

I’ve been using the verbal command, which has not been working. I also have tried the touchscreen approach which hasn’t worked either.

1 Like

I opened a ticket number two days ago but haven’t heard anything back yet: 2784226. Here is what I see when I open it on my Alexa app

When I drill down into it, there is no live feed. I do not have any of the subscriptions.

I too have tried every single one of these solutions. All of devices are up to date on the latest firmware. That includes the Alexas. I have 5 unifi hotspots with fiber internet so I know the internet is not an issue either.

Thanks for the information.

Would you mind adding your Camera to Cam Plus Lite? You can Name your Price at $0

This will give you person and the normal 12 second video’s, not just the image.

I am curious if it has to do with the lack of a Cam Plus or Cam Plus Lite.

I will escalate the Ticket for you as well

1 Like

Thank you for that note, as this was going to be one of my next questions. Also thank you for providing the ticket number.

Out of curiosity, would you be opposed to adding the Cam Plus Lite to the Camera to see if it changes the status of operation in Alexa. This can be free with the name your own price option.

1 Like

Added Cam Plus Lite. Did not work with that either.


When I look at the camera in my list of devices, the v3 cam specifically says “Live view unavailable in Alexa app” next to it, which none of the other Wyze cams do. If I tap one of the older (v1/v2) cams, I immediately see the camera view, but if I tap the v3 cam, it takes me to the camera settings page instead.

I have cam plus (not lite), currently on two of my V2 cams, not my v3. I can switch it around if that part is relevant in some way. It hasn’t historically made any difference in which cams I can view through the verbal command though, my V2 cams all show up, whether they’re on Cam Plus or not. Is that something that would make a difference with the newer models?

Ticket 2789343 submitted. I referenced this forum thread in the ticket, to help them know what all has been done as well.

I’m starting to think the v3 doesn’t work with Alexa all that well. Mine does the same thing. It goes to the camera settings page without a live feed. If you look at the skill reviews, there are a ton of complaints. I’m not seeing any issues with the v2. So thinking of returning the v3.

If you go to the Amazon listing for the Wyze v3 and search the reviews for Alexa Show, you will get 10+ other reviews with people stating the same. Here’s one for example:

All previous versions of these cameras would allow you to view them directly on your fire stick, echo display, fire cube, or fire tablets -all directly through an Alexa command so you could just say the name of the camera you wanted to view. This was a fantastic feature that adds terrific value to the product line.
These latest cameras won’t do it. You see a message next to them in Alexa that tells you it won’t work. I’ve checked Wyze support forums, and it appears people told them this over a year ago and they STILL haven’t fixed the problem, they just don’t seem to care about fixing it at all.

1 Like