About Wyze Robot Vacuum Firmware 1.6.126

Hello Wyze Robot Vacuum users,

As you may have noticed, we released the 1.6.126 beta firmware version with the multi-floor mapping function last week. Have you tried this latest version?

What’s new in 1.6.126:

All features require an app version of 2.20 or higher to use.

  • Added support for multi-floor mapping
  • Added support for turning on/off voice prompts
  • Improved the experience of resuming cleaning after recharging

First of all, I want to thank you all for your support and feedback on Wyze Robot Vacuum. Although we cannot reply to every feedback, suggestion, and complaint you have provided in the forum, social media, and app log submission system, we have read and discussed them carefully. We care about your experience with Wyze Robot Vacuum and will continue improving the product for our users.

Speaking of the multi-floor mapping function, we know that this is a feature many of you have been excited about and we have been working on it for quite a while. We believe that a good multi-floor function needs to be smart and easy to use for users.

For example, ideally:

  • The robot vacuum knows it is cleaning an unmapped floor and automatically saves the new map for the user
  • The robot vacuum saves the map without using the charging station
  • The user does not need to manually switch the map before cleaning another floor
  • The robot vacuum can store 5 maps to deal with different scenarios

On the one hand, due to current hardware and software limitations, we still need to make a lot of tweaks and updates to make before we consider this feature to be fully finished. On the other hand, we do want to give you a chance to try the current beta version and hear your initial feedback while we are still optimizing it.

How to use the beta Multi-floor Mapping:


  1. Move the charging station and the vacuum to the new floor.
  2. Open your 2.20 beta app and go to Home screen > Press “Map List” button > “Add a floor”
  3. The map will be saved once the quick mapping is completed.


  1. Make sure the charging station and the vacuum are on the desired floor.
  2. Switch the floor map in the app before starting cleaning.

Please feel free to share your experience using this beta version of the Multi-floor Mapping function. We would love to hear from you! We’ll make the decision for whether or not we include this feature in the next public release based on your feedback. If you encounter any bugs, glitches, lack of functionality, or other problems, please let us know immediately by submitting a log and contacting our Wyze Customer Support.

By the way, we also added support for turning on/off voice prompts in the latest firmware and the beta app due to your feedback. Now the voice prompts will not disturb your sweet dreams if your vacuum needs to work at night! You can find this toggle by going to Settings > Do Not Disturb > Turn off voice prompts

We’re not done yet! We will continue to improve this product and release more cool features. Thank you very much for your support!


The Wyze Robot Vacuum team


Hello, this is a long awaited function, but unfortunatly I can’t seem to get the firmware update. I am using the Beta app, v2.20.3 but the app is saying my firmware is current at 1.6.113. How can I force the firmware update to get this feature? I’ve been checking daily since I first saw this come up on the Reddit sub.


Have you checked the box to allow beta firmware for the vacuum in the Wyze app?

Account - About - Beta Program - Edit

Then scroll to add the vacuum.


I did not. That got it for me, THANK YOU!


Thanks for adding the multi-floor mapping. I’ve have enjoyed using it!

One of the features you already mentioned, is that it would be nice to map without needing to move the charger. Ideally, I’d just move the vacuum to the floor, it would map and then after vacuuming, return to where I placed it and turn off or go to sleep. Maybe allow the user to designate which floor(s) the charger is on so the vacuum knows what to do when on a floor without it?

The current issue I run into is since you need a dock to map, it then looks for that after vacuuming and because I keep the dock on the first floor, it spins around trying to find it so I have to stop the vacuum.

Overall, it’s a very welcome improvement - thanks again for adding this. I’m looking forward more cool features! :smiley:


Hi there, I’m Blake from the WRV dev team, glad you like the multi-floor mapping beta version! Thanks for your feedback! We’re still working on it. The multi-floor mapping function will become the “ideal version” with a few firmware and software updates.

Spoiler alert :wink:
With the new firmware to be released recently, the vacuum will be able to know it is starting a task on a new floor, then automatically map and vacuum the new floor.

Next step, the vacuum will go back to the start point after completing the task, instead of looking for the charging station on the entire floor.

Stay tuned! We will keep improving it!


Thank you for the feedback!
For this beta version, it will be required to have the charging station while cleaning on the secondary floors. We are working on an improved version that does not require the charging station and the vacuum will just go back to where it started after cleaning.


Excellent updates WYZE team!

An event to share
@WyzeHongfei @WyzeBlake

This morning upon an attempt to clean an area (Front Entrance) of my Primary floor, with my WRV I was greeted with an offline notification. Not uncommon but also not consistent, and my fix for this has been to reboot my IoT WAP. (I have a dedicated WAP to just IoT/Home automation and security) This resolved the WRV from being offline.

Upon returning to the Map I could not select any of my Rooms. In fact I cannot select anything on the map to execute a cleaning and the Room Splits are missing.

I tried a few of the standard troubleshooting steps, Restart app, force close, clear cache, rename the map. All with no resolution.

I have 2 mobile devices and the results were the same
Samsung Note10+
WYZEBeta v2.20.3
WRV FW v1.6.126

iPhone 12 Max
WYZE Production v2.19.24
WRV FW v1.6.126

Log submitted - Log ID: 199338

I am sure a remap will resolve this issue, but wanted to inform you of this event.
I will remap at another time and hold fast for now in case I can be of any assistance in testing.

Thank You

1 Like

Feature request: Multi Dock. Have a dock per floor if desired.

User Story: As a user I do not wish to collect the WRV if on a different floor from the dock if should the WRV need a charge in the middle of a cleaning session.

With multi dock (at a reasonable price point) I can add a dock per floor (as desired) and let the device function with less user interaction.

1 Like

Update: after consulting with one of my esteemed colleagues @spamoni4 a, remove from dock, power down (rest for 5-20) minutes, power up, return to dock via the app, (not manually) seems to have corrected this issue.

Sent an additional log for comparison if interested LogID: 199449

1 Like

That’s weird, we will look into the log and get back to you. Are other setting options still responding?

Thanks for the feedback. Definitely agree with you! We will support this feature and make the charging station available to purchase on wyze.com store. We are working on it.


I see. Thanks for your update. Usually, if the home WIFI disconnected, the vacuum will repeatedly attempt to re-connect for a period of time, if it could not successfully re-build the connection to the router (for example, the home WIFI is still down), it will stop trying. In this case, reboot the vacuum itself will be necessary so the vacuum can start connecting again.

I have been working with @Rui on my issues. I also submitted logs. In my case, and maybe the same with @R.Good, When I experienced my issue I looked at my router and the Wyze Vacuum was still connected with Full Signal. But yet the app displayed the dreaded no internet or connection. In one of these cases, the Vacuum continued to work and when done, it returned to the Charging station and then everything cleared up and showed as if there were no issues. For me, this started with the latest build.

Here is my topic:

Yes, everything but the map was working. I could not initiate a cleaning because of it.

The reboot of the IoT WAP resolved the WRV not being connected, that was problem 1.

Problem 2 was once the WRV was connected the map had no room splits the room titles were still there but I could select nothing on the map to initiate a cleaning. Removing the WRV from the charging doc, powering the WRV for 20 min, powering it back on, then returning the WRV to the charge doc from the app, not manually, resolved the map split lines being gone.

Thanks for the replies!

Thank you for finally adding a way to disable the voice prompts! I’ve been waiting for that option for so long… The do not disturb function is nice but it only applies to the voice right?

Maybe there should be a way to turn off that bright blue charging light at night too during do not disturb hours or just turn it off all together. It is very bright and can be hard to sleep when the robot is in the same room charging at night.

Is there a way to add a do not disturb mode so that if the robot has to go back to charge in the middle of a cleaning and it’s already past a certain time… The robot doesn’t try to go clean again later at night after is charged when you are asleep?

Similar maybe to this post.

1 Like

Have that light on my mobile phone charger. Had to tape over it to drive on those long mountain highways at night. More disturbing then deep red. :sunglasses:

@Rui and @WyzeHongfei

Weekly Vacuum kick off. So far everything is working. However, When I am in the app and look to see how it is doing, the Map blinks or displays then disappears and then comes back.

Log submitted: 200883
Vac FW: 1.6.126
App Ver: 2.20.3 - Android Device

Below is a video of what I see. You will see it vanish, comeback, vanish, etc. I only recorded a portion of it.

1 Like