2.20 iOS beta app hotfix & Wyze Robot Vacuum Firmware Beta Test 4/28/2021

version: 2.20.131(7)


  • Fixed a bug preventing Wyze Lock notifications
  • Fixed the widget display


Firmware version: 1.6.126

What’s New:

*** All features require an app version of 2.20 or higher to use ***

  • Added support for multi-floor mapping

  • Added support for turning on/off voice prompts

  • Improved the experience of resuming cleaning after recharging


Multi-floor mapping - wahoo! So excited to try this out! :smile:



Could we get an option for voice prompts on error only? It would be nice to know if the vacuum is stuck on something. Glad there is a way to turn it off though, good feature.

Nice to see the multi-floor added.

I’m also going to going to use the multi floor as a way to store a good copy of a map in case the robot continues to update the map incorrectly, so I’m also glad for it in an non-obvious way. It would resolve the following problems:

If I open a door, the robot doesn’t seem to see an interior wall as a wall and instead then treats my entire floor as one room. I can’t create a fake partition if I wanted to as the “split” room only goes to dark green areas not light green - if that makes sense.

So my work around is doing a quick mapping with one door closed so it forces it to see that interior area as separate. Unfortunately if it cleans with the door open it wants me to update the map after and sometimes I click it without thinking, thus creating the one large room issue.

Ideally it would be nice to store a “previous” backup version or add the ability to create walls that allow for the division of rooms - actually both would be good. The hard walls would be good in case the algorithm thinks something is actually connected but inaccessible, when its really not connected at all.


Good Idea of the Map “backup” Im going to try that too.
Only problem is if you have to ever reset your vac to defaults that will still be lost :frowning:

Thank you Wyze! So happy to see this!

1 Like

Installed the Vacuum FW, definitely like the updates. May have missed this, but if you setup multiple floors (Which is a great option), will we be able to get extra Charging stations? If your second level is large enough and it has to go back and charge, how will it know where to go if the charger is on another floor. :slight_smile:


I had the same exact thought… wish list :grin:

1 Like

Great update. However where is Alexa integration. I want the ability to clean my floors without having to get up my phone or tablet. This was one of the key reasons I bought this vacuum instead of a competitors as it was in the roadmap for the first half of this year which is quickly coming to a close.


For the second floor do you have place the Vaccum in the same starting point every time for it to work? If there is no charging station on the second floor, what does it use as a reference point so it knows where it is?

I’ve only had a chance to map/vacuum another room on my 2nd floor once, but I brought the dock upstairs and did a quick map. Once that was done, I moved the dock back downstairs and I picked up the vacuum and moved it to a different location in the room it just mapped. When I started the vacuum, it spun around and was able to correctly tell where is was in the room. It did it’s thing and vacuumed, but when it was done, it tried to go back to where the dock was. Since it couldn’t find it, it spun around for a bit. I let that go on for a minute or so and then I just stopped the clean.

I’ll have to test it more, but so far I’m happy with it. Since I only plan on and want to have just one dock in the house, it would be nice to be able to map and vacuum different floors without the dock. The default behavior could be to have the vacuum return to where it started vacuuming.

1 Like

Now that I tried it, I saw that when mapping the second floor, the instructions state that you should bring the dock upstairs to begin mapping. That implied to me that you need the dock for it to know where home is. Without the dock, I can’t see how it would know where it was in order to see what room it’s in and where to go. Would be cool if it did.

I installed the new firmware and I have to say the new multi-floor cleaning feature is :fire:. Thanks for getting this working. I’d like to second the desire to be able to purchase another dock for the other floor.

One thing I noticed is when I went into the floor selection/editing screen, I saw 2 different maps called “My Map” - I guess this explains why the saved map would sometimes disappear and the vacuum would appear to create a new one. It didn’t forget the old map, it failed to recognize the place it was in and so it created a new floor map and saved the old one. Interesting.

Now if you would just start selling replacement batteries for the vacuum, it would be amazing! :grinning:



New here. Where do I pick up this Beta Firmware?

Thanks in advance,

Welcome to the Forums

You will first need to subscribe to be a Beta Tester. Go here for that: Become a Beta Tester – Wyze and install the Beta App.

Once loaded:

  • start the app and go to Account tab
  • Tap on the About Menu Choice
  • Tap on Beta Program
  • Tap Edit in the top Right
  • Then Select the Devices you want the Beta Firmware for, or select all. I select all.

Once this is done you can go back to the Account Tab and tap on Firmware Update and see what is availabale.

You should note that some times you will need to go to the Device and check via the Device directly.

Just ran a cleaning today and had some issues. I created a log and added to another post I was working in and tagged @WyzeRui on it as they were working on the last issues. Here is the writeup:

@WyzeAndy and @WyzeRui is is a copy of my issues…


Hi, the dev team is working on this. With the work-in-progress firmware, the vacuum could go back to the start point after completing the task, instead of looking for the charging station on the entire floor.

1 Like

Thank you Wyze! This is good news

Why isnt the IOS app in the app store not available for an upgrade. It is still showing the 2.19 version and the 2.20 version doesn’t seem to be an option. Please let me know.

The 2.20 has not been officially released yet. If you want to try it, please join the Beta Program :wink: