2.23 App Beta Test 7/21/2021

  • iOS: 2.23.11 (2)

  • Android: 2.23.12

  • Added support for unlocking Wyze Lock from the Wyze Video Doorbell page

  • Added support for location-based Rules triggers based on arrival or departure from a location

  • Added support for repeat schedules for Wyze Sprinkler Controller

  • Added animation playback and sharing for Wyze Robot Vacuum

  • Added Wyze Robot Vacuum status to the Home tab

  • Added weight comparison to the Wyze Scale page

  • Prevented firmware updates when Wyze Cam Outdoor has low battery (iOS)

  • Fixed a bug that prevented downloading time lapse videos for Wyze Cams (Android)

  • Fixed a bug that turned off motion detection for Wyze Video Doorbell (iOS)

  • Fixed a bug that prevented Wyze Bulb Color sleep routines (iOS)

  • Fixed a bug that prevented the display for weekly/monthly calories for Wyze Watch 44mm (iOS)


Still no way to arm/disarm alarm by location. :frowning:

How do I set up the location-based rule triggers? :thinking:

Installed on iOS and Android devices. So far everything seems to work.

Will now begin testing.

Will definitely test this out.

Question: Will this eventually be able to take into account all members of the family an presence. For example, I want to set the HMS to Arm Away when no one is home, that means this feature should take into account all members of the house. Just curious on this.

1 Like

I may be missing it, but I had an update to the WCO and Base as well. The beta Firmware is as follows

Camera is
Base is

Anybody know what is included with this update.

First potential issue. My Vacuum Map is messed up. It was fine prior to the update.

Below is my map, the OFC , BR, MBR is not appropriate spaced. the Door to the OFC is missing, there is an extra bump out to the right of the LR. To the Right of GR there is a Box shape which does not exist. etc. Do I need to remap the house again? I may test the run on Saturday without remapping first to see what happens

Is updated firmware needed? I don’t see a option to unlock the Wyze lock from the doorbell.

1 Like

Ok, so you have to add the lock in the accessories page in the doorbell settings. Working now

1 Like

I still don’t know how to create location based rules. Appreciate your help. Thanks!

It is only available to those testing the new Rules Engine. If you are not on the new Rules Engine and would like to be, you can let QSun know. Here is the link where they offered it:

However, when you go into the App, Click on the pencil in the top right and select edit rules or the Plus sign in the top Left and select add rules. If you used the pencil, click the plus at the top right to add a new rule.

you will see the following screen, last option is location trigger:


I don’t see it. So it means I’m on the old Rules engine. Will send a mail. Thanks!


@WyzeYichen , @WyzeQi
Loaded - on Samsung Tab A SM-T510-
Didn’t solve the crashing to Android Home screen when displaying 4 cams in group view, but made it better.
First time it didn’t crash back to the Android home screen for over 5 minutes. The record yesterday was about 30 seconds.

When I tried to set the location, the screen where you put the text in the box maximized and covered up the map. I could drag it down, but it would snap back up. Took about 20 tries before I could expose the map and click on the save button.

And when do get we sunrise/sunset triggers?

Hi @gemniii could you record a short video for this operation?

The sunrise/sunset feature is in development.


Hi @superchi you can send me your email address.

1 Like

Hi Spamoni4, escalated your issue to the Robot Vacuum PM! Thank you for bringing it up and sorry for the inconvenience!

1 Like

Appreciate that, no inconvenience as this is what I signed up to do - test beta releases for you :slight_smile: .

FYI: I am not going to remap, want to see if it clears itself when it does the scheduled cleaning on Saturday. I will let you know.

1 Like

Hi @spamoni4, this sounds weird since the 2.23 update should not change the map. Can you help me try checking one thing: press the ‘pen’ sign, choose ‘Customize rooms’, then check if the map shows in under the ‘Customize rooms’ page. If that map is messed up, please do a remap. If that map is fine, you can just start another cleaning mission and the map shows on your product page should recover. Let me know if you have any questions.

I’m on the new rules engine running beta v2.23.12 and don’t see location-based rules either. I think you need new rules engine and also be white-listed to location-based rules.

Just did what you asked. The mO looked fine when I chose the customize room. Not sure why it is different in the main screen. I will see what happens tomorrow morning as that is when the cleaning happens.

That is interesting. QSun said this :

Currently only open to users who have been in the new Rule Engine.

1 Like