WyzeCam Blinking Blue Light


I had 2 wyze cam v2 that has been sitting in box for over an year. I already have one installed and working well. I tried installing the 2 new ones today. Both of them got installed and went through firmware upgrade & hung up.

I had to download the firmware in SD card and flash it as recommended in forums. When I did this it it went from yellow to blue light and after few minutes the camera rebooted with yellow followed by flashing blue light. Now both the camera are stuck here as they both are flashing blue light. I have already deleted these cameras in my app and don’t know how to put back to factory setting to install again. Any help would be appreciated, I already tried power cycle


unplug while doing so, hold down setup button for 40 seconds after plugging in.

Here is some info on how to Factory reset the cam and how to locate and re-flash Firmware.
Factory Reset

How to Find Firmware

Manually Flash Firmware


Same issues here. Cam v2 is stuck in light blue flashing. I’ve tried repeatedly to flash the firmware and it always goes to light blue. No factory reset or flashing or holding down buttons seems to work.