Issues with reverting my wyzw cam v2 from webcam to security cam

Hi all,
I tried multiple times to reconfigure my wyze cam v2 as a security camera (I reconfigured it a couple of months ago as a webcam).

I followed all the steps from:
…but the light is blinking blue/yellow for 30 mins and nothing happened.

Following other comments found here:

… I also tried with an older version of the firmware (, but it didn’t work. The version that worked for other users ( doesn’t seem anymore available.

Please could you help me to solve this issue?

Thanks in advance,

I want to make sure I understand what you are saying. You had previously flashed your camera for RTSP, and you are now trying to put “normal” Wyze firmware back into the camera. The procedure is exactly the same as you did to initially flash the camera for RTSP - except obviously a different firmware file to put on the uSD card.
If the status light is blinking yellow / blue it sounds like you did not hold the setup button when you powered up the camera (takes about 6 seconds from my experience to get the both yellow and blue indicating a firmware load). Also remember that it MUST be no larger than a 32GB uSD card.

I was having the exact same problem, just double check the latest firmware and to make sure that the file is just named: demo

In the instructions they said demo.bin, but .bin is the extension of the file, not need to put it.

Check that option and let me know

I was having the same problem with the OP
I had downloaded the latest firmware file, put it onto a 32GB MicroSD card, and held the reset button while I powered it up. The amber light would always just start blinking “light blue”.

but I had not removed the version from the file name.
Once I renamed the file to just “demo.bin” it began the process and installed the firmware correctly.

Hi all,
Thanks for your help!
It finally worked. The problem was due to my micro SD card that was larger than 32GB. For some reasons the 128GB card worked when I converted the wyze cam to a webcam but didn’t work when I tried to revert it to a security cam. After I bought a 32GB, everything worked.
Thanks again and happy new year!

Does anyone have these reverting instructions? They don’t seem to have this page posted anymore: [ ](