Firmware wyze cam v2

Hello I have one of my wyze v2 cameras that when connecting it only turns on the yellow light and so it remains. I have downloaded the firmware for my camera and followed the procedure according to the instructions. I have the demo.bin file on the SD card, I have pressed the configuration button, I connect the camera to the electrical network and nothing changes, I have tried taking more time than wyze advises and nothing, it never changes to blue light.
Could someone give me some advice on what else I can do?
Thank you very much, alvmontilla

1 Like

I’ve the same problem with 2 V2’s

Hi @alvmontilla and welcome to the Community forum!
It sounds like you’re doing everything right. When you say “taking more time” may I assume you mean holding the reset button down after plugging in the USB power cable?
Is the uSD card 32Gb or less and format in FAT32?

If all that is true,
(1) Leave the cam powered down overnight.
(2) Reformat the uSD card in a PC. e.g.

  • Reformat the uSD card on your workstation and un-check the default “Quick format” option which will force a complete overwrite of the card and fix or lock out bad cells.

Alternate Method:

  • From ‘Properties’ or a Command Line,
  • Run chkdsk x: /r where x is the drive letter to double check the uSD card.

Copy the demo.bin over and try again.

1 Like

Thanks for the answer . I will try.

1 Like

Let me know how it works out for you.

Why leave it unplugged overnight? Any caps will discharge completely in a matter of minutes

I am having a problem loading rtsp on a wyze cam 2. Have followed the directions from there web site.
I insert the sd card with renamed file and try to reset as per instructions. I get a message that the camera wants to reconnect. The camera is already on my phone. Loaded latest firmware on sd with same results. Have tried loading standard firmware and it works find. Go to load rtsp and it still wants to reconnect with phone. Any thoughts on how operator error is involved?

Did you simply copy the downloaded file to the SD Card or did you extract the .bin inside the zip?

I downloaded the file. Went to show in folder. Extract all. Renamed file demo.bin. I can open file and see 25 files. Properties show size 20.3mb size on disk 20.4mb and contains 374 files and 40 folders. I have 3 other cameras that are running
Tempted to remove card with and try on this camera.
Have used 2 sd cards to try to install. Both where formatted in camera, them windows, then in SD card formatter. try to load on the camera in question and it shows Firmware version
Thanks for any help

You mention you use Windows…by any chance did the file get named “demo.bin.bin”? By default, Windows hides file extensions and may have added the extra .bin when you copied the file.

Sorry for the delay responding. I was out of town all day yesterday. I have a friend that runs Linux.
I will ask them to prepare the sd card in that os. I will keep you posted on the results.
Thanks for your input on this matter.
Looking to set up a remote dvr for these cams so that I don’t pay for cloud service.
Any thoughts on that?

You will need RTSP firmware to do anything like that. Blue Iris seems to be one popular choice. Others are using NAS solutions.

I believe if we are able to reverse engineer the firmware these cameras use we could make useful changes.

I like these cameras. Seems that they are more interested in building new products than supporting the old ones. I think most people would like to keep recordings at a different location than the cloud. If they have the staff to develop new products, they could come up with a good windows platform. My bad, they won’t be able to make money off of cloud storage. I will get this resolved or buy a different product.
What is a good NAS solution?

Mostly seen Synology…

Sorry for the delay in response. I have been out of town. Trying to load rtsp on a wyze cam 2. I tried formatting the sd card in windows 10, unzipped file (, renamed demo.bin as per instructions. Didn’t work. As per previous post I had a friend do the same in a Linux machine with the same result.
My friend teaches a STEM program for Purdue University and he can’t get it to work . Any suggestions?