Wyze Cam v2 firmware upgrade failed. Now cannot recover

I have a Wyze Cam v2. I forgot what the firmware version was but I believe I updated 1-2 months ago. Last week, I tried upgrade, the firmware update run all the way to the end but says firmware upgrade failed.

The Cam appears to be still responding. I have since tried a few more times with the same failed result. Today, I noticed the camera is offline. I switched a power supply and cable just in case it is the problem but the situation does not improve.

I tried removing the camera and re-add. I can get the camera to “Ready to Connect” (sometimes, it is just the chime, no spoken words. But when I try to scan the QR code, nothing happens. And the LED appears to be off.

I tried factory reset. I tried manually upgrade firmware using demo.bin with latest firmware. I don’t think it is loading the firmware because LED never changed to bright blue. If I leave it on for a while, the light will even turn off. I know I have never set the camera’s indicator off.

Any ideas?

1 Like

I had same issue for .156. won’t update even Wyze tried to upload it.

Then my sd card crapped out.

remove your sd card and see if starts.


Make sure the file is demo.bin and not demo.bin.bin. it didn’t work for me for a bit because I didn’t know one of the extentions was hidden. What size card are you using? I’ve only had success using 32 gig or 16 gig cards. I’ve heard smaller cards than that work, but anything over 32 won’t.

1 Like

My Windows doesn’t hide extensions so the file name is right and I am using 32GB MicroSD formatted in FAT32.

I let the camera sit there powered on for a while and I think I heard the IR filter cutting in and out. I think camera is going through a boot loop.

Given that sometimes I only hear the ready to connect chime and no “Ready to Connect”. I think it just rebooted at that point.

1 Like

The status light will be a combo of the blue and yellow status lights on at the same time. After 5-6 seconds of holding in the button after powering on.

Like @cf7 asked, have you tried taking the sd card out and powering the cam that way?

1 Like

Without SD card, it behaves the same. Will not come online. Still getting stuck after “Ready to Connect”. No confirmation of QR code scanned at all.

1 Like

your last act is to get a 32gb or smaller sd card.
download firmware version you want.

manual flash it again.

1 Like

already done that before my first post.

If it is out of Warranty period, V3 or other brands.

Hi, If you are still experiencing issues, I would recommend contacting the awesome Wyze support team. You can call them at 1 (844) 999-3226 between 5 am-6 pm PT Monday through Friday, and 8 am-4 pm PT Saturday. You can also visit the link I have linked below for other means of communication with Wyze support.


1 Like

Hi @wzeuser & @cf7 The latest Firmware for the V2 is (October 21, 2020) :slightly_smiling_face:
Test if you have a corrupt uSD card:

  • Remove the uSD from the camera and test it in your workstation.
  • Check the disk with the command line C:\Windows\system32>ChkDsk X: /r Where X is the uSD card
  • Format the uSD card FAT32 and un-check the default “Quick” option so it can mask out bad cells.
    Note: The Format from the Wyze App is a Quick Fromat

Quick format just marks the partition as “formatted” and destroys the journal that keeps tracks of the files and their locations on hard drive.

Full format will clear files completely from the partition, rebuild the file system, volume label, and cluster size, and scans partition for logical bad sectors; that’s why full format is slower than quick format. Wyze devices must always use the FAT32 format.


I had a similar, maybe same, problem with a new campan that failed the first upgrade before I even used it. WYZE support couldn’t help me fix it so they sent me a new one. It succeeded it’s first update worked fine. Since WYZE didn’t want the old one back, I experimented with it.

It would not load an image from the SD card, like yours. I could see the demo.bin in the root directory when I put the card in my Ubuntu Linux computer. I tried quick reformatting the card, but it didn’t help. I then chose the option to do a long format of FAT32, erasing all the data on the card. It took about 1/2 hr for 32 GB card. It then booted from the card, but my finger slipped off the reset button mid way. A second boot up try failed again. Another long format and it fixed it again, this time I used a q-tip to hold the button more firmly. The firmware loaded and the camera works and upgrades! I suspect that the bad firmware from a failed upgrade corrupts the card to be not bootable (corrupt MBR?) if it is powered up with the card in and the reset button not depressed, even though the card can be read on another computer. The long format restores the MBR or whatever a SD card has. Years ago a non booting disk with a corrupt MBR could be repaired with the DOS command “fdisk /mbr”.

Maybe try another card or find some way to do the equivalent of the Linux long format on whatever OS you use. Maybe the fdisk command is still working that way on modern Windoze. I don’t have it to test with.


1 Like

Hi @jweber and welcome to the community!
Glad you were able to solve the trouble and provide your solution here on the forum. It may be helpful to others.

You can still format FAT32 in windows. For larger cards, recomend using This Standard Program to format.

The Master Boot Record (MBR) tells the computer where to start and not really needed buy the camera. There are options to do a ChkDsk repair in Linux. e.g. sudo dosfsck -w -r -l -a -v -t /dev/sdc1

Sorry guys. I realized I made a mistake. It came to light when I wonder why would someone named the file demo.bin.bin by accident when the file has an extension of .zip. Then I re-read the manual firmware instruction I realized that I need to first unzip the files to .bin and then rename. Now it is working!


I am glad to hear you figured everything out!

1 Like

Thanks for the update! :slight_smile:


on my Cam v2 I originally had and was having alot of issues with detection zone.
So I flashed firmware to latest (at time however, after flash it failed. I got the solid yellow light,
As I troubleshooted, nothing worked from what i found on this site.

How i fixed this issue.
I went into app and deleted the camera from app… (at this point, a full redo is best)
I downloaded firmware version July 28, 2020
I formated my micro SD card to FAT32 newer windows 10 dont allow this, i used mini tool partition (free) to format this version. No other format file will work.
After formatting the card, I dumped only the file in the card as demo.bin
Then I followed instructions from this site. (it worked, i am back in business)

  1. Wyze Cam v2 and Pan firmware files can be found on the Release Notes page.
  2. Download a specific version of firmware, For Windows 10: Right-click on the folder and select extract all. For Mac: Just drag and drop the folder, put it on the root directory of your microSD card. For both Mac and Windows, rename the file to demo.bin .
  3. Power off your camera and insert your microSD card.
  4. Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid blue, then release the button.
  • Note: The “Solid Blue” in this case is not the same as the one normally seen on the camera. Instead, both the blue and yellow LEDs will be on at once, making it appear to be a lighter blue.
  1. Wait for 3-4 minutes. The camera will reboot and change light status during this time.
  2. Once this is done, your camera should be functioning with the original setup. No need to re-setup your camera!
1 Like

You got it @papa_tejas and welcome to the communtiy forum.
Good job! :slightly_smiling_face: Hope others read your post.

1 Like