Wyze Cam 2 dead after update and failed manual update?

Just joined, so many posts, so I’m trying to find out if my Cam v2 is fully dead. Tried to connect and it worked and began to update. The update failed and the camera would not respond after that. Tried a manual update, but though the camera ‘clicks’ the light doesn’t turn from yellow to blue.

Just need to know if it is dead forever. Thanks.

Did you try a different power adapter? I’ve never had a V2 but it is probably a 5V - 1 A power brick. Just a thought.

For manual update use 32GB (FAT format) or smaller micro sd card.

The light not changing means the flash isn’t starting. Any number of problems.

32gb or smaller FAT32 sd card

Correct firmware version for camera.(https://support.wyze.com/hc/en-us/articles/360024852172-Release-Notes-Firmware

Not holding the setup button down while powering on the cam.

WildBill,

Did all of that. To reiterate, connected the camera and it went immediately into update. Updated for a while and then suddenly failed. Wouldn’t reconnect after that. Deleted and tried to connect again but could not. Downloaded the correct firmware, copied it to a 32GB AT32 flash card, held the setup button down, plugged in the power cable, holding the setup button down for up to thirty seconds (no easy task) and though camera ‘clicked’ the light would not change to blue.

Tried this several times.

So, do you think it’s bricked?

Thanks.

Mike

1 Like

Just wondering if perhaps you forgot to unzip (decompress, extract, etc.) the source firmware before copying to the card. Also, make sure the only file on the card is the firmware and the filename is demo.bin.

https://support.wyze.com/hc/en-us/articles/360031490871-How-to-flash-your-Wyze-Cam-firmware-manually (scroll down to Flash Firmware for Wyze Cam v2 & Wyze Cam Pan)

1 Like

I was just about to suggest the same thing.

@mikebravo , it just appears that the camera isn’t reading the firmware file. Maybe try a different SD card. I’ve seen posts here on the forum of people repeating the flash process multiple times before it works.

1 Like

Going to try that, thanks.

1 Like

Scared me. But, yeah I unzipped it. Thanks.

1 Like

Well, tried everything. Multiple flash cards, reformatting, cleaning the guts of the camera with compressed air, multiple firmware files going back as far as I could but no joy.

I think it’s bricked.

Thanks anyway.

Mike

1 Like

I really don’t think it’s the camera. But it really comes down to how much time and effort you want to expend trying to fix it. Still sounds like the camera isn’t reading the file. If you have another camera you could test on it.

Two more thoughts…

What is the name of the file you are downloading and what is the name of the file after you copy it to the SD card?

Are you certain you are holding the setup button down during the power-up? I’ve had difficulty with that and have used a smart plug to control power. Much easier to hit the power button on the plug rather than trying to hold the setup button while trying to plug in the power cord.

When you extract the file for the latest V2 firmware it looks like this:


When you change the name it should look like this:

Copy and paste demo.bin to the SD card.

2 Likes

That’s a new tip. I’ll try it. Thanks.

Make sure it is renamed to demo.bin demo dot (period) bin

Going to try that, thanks!

Alright! That worked perfectly and the camera is up and running.

Thanks for your help.

Mike

1 Like

A tip from Antonius had me renaming the flash file eliminating the version number and that did it.

Thanks for your help.

Mike

1 Like

WildBill and I posted the same about filename change up above. It’s also in bold text in the Wyze instructions. But really great to hear you have you cam back up and running! beer2

Glad to hear your cams are back up and working. Written directions are good and correct but sometimes pictures make it easier to understand. Trust me, been there and done that. :grin:

A tip from Antonius had me renaming the flash file eliminating the version number and that did the trick.

Thanks for your help.

Mike