Cannot reset my Wyze V2

I had an issue before with getting a camera to reset, and spoke with a tech via chat. They instructed me to download some firmware and to manually flash the firmware. That solved the issue with that camera, but it will not work for this camera. When I plug it in, it starts off solid yellow, then goes to flashing blue. All I want to do is factory reset it so I can go back and set it up. How can I accomplish this?


I have attempted that multiple times today and it has not worked.

When you push the reset button do your hear “ready to connect “?



No, nothing happens at all, the blue light just keeps on blinking. I tried to upload a video which would have better explained what I have tried and what does/doesn’t happen, but because I’m new to the forum it wouldn’t let me.

Have you deleted the camera from the Wyze app and reconnected?
Make sure you are on a 2.4Ghz network and using the WiFi password & not adding spaces via spell correct from your cell phone.

1 Like

Yes, deleted off the app and I have WiFi, my other 4 cameras are connected to the WiFi and doing just fine. This one and one of the other ones were connected by a power cable, and they were having issues so today I gave them their own direct power source and the other one is working just fine, but this one wasn’t. So I attempted to reset it (this all started 8 hours ago) and I have not had any luck.

1 Like

Leave the power off for camera for awhile, remove the uSD card, press and hold the reset 12 seconds w/o power. Then power up and try again.

I will try that in the morning then. That should give it enough time powered off.

After having the camera disconnected from power all night, I tried your suggestion and it still only keeps flashing blue after the initial startup. Been flashing blue for about 2 hours now.

Wow, That camera is really stubborn. At this point I can only think the internet router is having a mutual zugzwang w/V2. You could power down the router for 10 minutes and try again.

What type of camera is having issues? I didn’t see that mentioned yet. Edit, nm, in title :stuck_out_tongue:

Would it only be effecting one camera and not the other 4 though?

Could be several problems. The router DHCP may have a conflict and the camera my be refusing the new IP address (check the log). There can be a stuck communication link pinned down at the ISP or w/AWS. Its worth a shot and does work w/obscure problems.

You’ve already manually flashed two cams and only one V2 didn’t work so that doesn’t seem a likely problem.

Reset the WiFi, and disconnected the power to the camera before restarting the WiFi (even did the 12 second reset button hold while powered off) and it’s been blinking blue for 10 minutes now :cry: I’m about to give up and buy another camera I am so frustrated with it!

Is the WiFi router same unit as the Internet Router? Maybe time for a Support Ticket

Yes it is, it’s all the same device.

Did a search on V2 reset and couldn’t find anything new. Corrupt uSD card? no. .
Will track this thread. Post an update here if there is a solution. Thank you elfwolfe!

1 Like

Is the sd card in the camera during all this testing? Take it out now reset if it is.

No, when @dr.know told me to remove it I did and it was not put back in. That was 14 hours ago.