WyzeCam App not accepting my (working) password

This is odd. I’m still awaiting my 4 v2 WyzeCams. I’ve obviously registered an account as I’m here, on my Mac, posting. The credentials here for the forum are the same for the WyzeCam account.

I just downloaded the iOS app to my iPhone. The app is telling me my password is wrong… the password I’m using now to be logged in and posting this issue. When I try, “Sign Up,” it tells me the email is in use. (Of course, it is.)

I use a complex password… over 16 characters including upper/lower case letters, numbers and symbols.

Before I go nuts with the whole “Forgot Password?” routine, does anyone have any idea why I’d be perfectly able to log in to WyzeCam.com on Safari on my Mac, but not log into the WyzeCam app with the same credentials?


1 Like

Figured it out almost by accident. I was watching the setup video on account management and it was mentioned that passwords need to be between 8-16 characters and mine was 24. Oddly, the system allowed me to reset my password using a 24 character string… BUT it would not let me log in elsewhere.

Reset password on iPhone using 24 character string. ALL GOOD.
Try that password on Mac? NO GOOD.
Reset password on my Mac using the identical 24 character string. ALL GOOD
Plug that password into the iOS app? NO GOOD.

Solution? Use a 16 character password. It’s just weird that it seems to half-work with longer passwords.

Moral of the story?

a) When you ask someone to create a password, EXPLICITLY explain how long and what characters are allowed.
b) Passwords should really be longer than 16 characters. :slight_smile:

I don’t know, except that maybe for some reason the phone won’t accept one of the special characters. How about changing your password here on the web and leaving out one of the special characters then trying again on the phone? You can change your password by clicking My Account at the top of this page, and then Account Details.

Wow! Thank you nicholsd. I encountered the exact same issue. It seems that setting my password to 16 characters works for now.

Wyze has some of the worst UIs in the business. I was also having trouble logging in to the app, using what I knew to be the correct password. PWs are usually limited in the number and types of characters, but I never heard of anyone stipulating an exact number of characters, and making users guess which ones are not acceptable. Logging onto the forum is also a minefield: even after logging into the site, the forum demands I establish a user name. Would that be the same user name use to log into the app? If I change it on the forum will that invalidate the one I use on the app or the website? The cameras are amazing; perhaps Wyze needs to bring a few of those engineers over the UX side.

1 Like

the forum demands I establish a user name.

@danwriter I think you are confusing username with email address. The forum needs you to establish a username. That is the name by which you are known on the forum and which others can tag you by (as I have done here). This is different than the email address you use for registration in the Wyze app, website and as login credentials for the forum. You would not want your email address used as your forum username which would expose it to the world, a security risk.

1 Like

I am having a similar issue. I can login to the app with my UN and PW just fine but I cant login to the website with the same UN (I use my email and NOT by UN through forum) and PW.

Same thing for me!!! Wyze needs some security HELP!

I am having a similar problem. I have an email/password combination which let me sign on to the webpage but wouldn’t let me, entering the same information, to log into the app. This is bologna! So, I think maybe I just keyed it in wrong and try again…now I am informed my account is locked, that I need to change my password. So, I go to do so, and it requires a verfication code from email…so I wait…no email.
It is like they are forcing me to hate them!

1 Like

Would you guys consider replying to a post once in awhile?
I haven’t seen any answer to this question…not even a hello, we’re sorry, we’re working on it, nothing!

1 Like

@paulhathaway, sorry to hear you’re having issues. Please keep in mind Wyze doesn’t have live support over the weekends, and the moderators are volunteers not employed by Wyze. I will ping some Wyze employees to see if they can help you. Have you already submitted a support ticket with Wyze? If so, please post the support ticket number here in a reply. :slight_smile:

We’re sorry to hear about this. That does sound frustrating! If you have a support ticket number, I would be happy to draw attention to it from our side. If you don’t have one, please fill out this form and let me know what number you receive in a reply email. We apologize for this and will resolve it as soon as we can.

Submit a request – Wyze


Wyze ticket number 224566

Thank you, Paul! I’ll send this over to the team. They’re already out of the office for the evening but I’ll see about getting you a response soon. :slight_smile:

1 Like

Hi, the same thing happened to me, it just started today when im out of town. I uninstalled the app, reinstalled and still doesnt let me in. Email/psswd are correct. Message says ‘verification code failed’ and doesnt let me in the app or send a code to email? 1st time this has ever happened. Could it have something to do with phone carrier, it also wouldnt allow access to carriers internet. Had to connect to wifi as guest user? Thanks! Im sure its something simple and fixable.

Not sure what changed but its working now. Thanks!

My issue was that I had an email rule set up to move any email with a from address starting with numbers or odd characters to my junk folder.
The second email with the verification code is sent from an address which starts with “<” which triggered my email rule.

So, the verification codes were in my junk folder. I tried again and the problem was solved.

Thanks! Ill check that.