Password working in Wyze App, not working on Website

I am able to log into the Wyze app using a newly created 10-character pwd; however, this password does not work at Initially, after reading the forums and finding the minimum 10-character password rule, I assumed the issue was my 9-character password. Did a password change to 10-characters following the pwd format rules, but still unable to log in on the website. Has anyone else experienced this and found a solution? The “Contact us” links all get directed to a basically worthless bot.

Welcome to the Wyze User Community Forum @trpjazz! :raising_hand_man:

When you try to login to either or, is the Captcha checkmark loading at the bottom of the screen for you to check?

Do you have 2FA enabled?

Are you typing in the PW or are you using a password manager? I know Android has an embedded PW Manager, not sure about iOS as I don’t use it.

Have you tried to copy the PW from wen you enter it into the app, just before you click Sign In and entering the app, and then paste that into the PW field online?

Is your login email a GMail account? If so, have you tried the Login with Google?