Wyze Watch - Automatically disable constant heart rate monitor while charging

If you charge at night, continuous heart monitoring must be disabled to avoid being woken up by the sweet green rave party strobe emitting from the bottom of the watch every 5 minutes. Please have the watch automatically disable heart monitoring while charging.

hell I’d love it if it just stopped if I take the watch off and leave it on the desk, programming wise all they need to do is if watch does not get a heart rate after three attempts it will stop and only check once every hour until it does get a reading.

How Do you enable continuous heart monitoring on watch 47

Swipe right to left on the watch so icons show up, swipe from bottom to top and the last one will be the settings gear, inside there you will see ‘Heart Rate’ turn that on

Thx for that!! Not much on info with instructions.

Continuous heart rate monitoring should be automatically disabled when the watch is not being worn. Yes, you can manually disable this, but who would remember to do this every night when you take it off. Currently, you can watch the pretty led lights flash, and the battery drain, as it counts heart beats of the night stand. :wink:

The latest Beta Firmware for the Watch 47 disables the Heart Rate monitoring when being charged. Here is the item description

and here is the complete description of the what the FW fixes or adds:

This needs to be automatically disabled/paused while charging.

When you have this option enabled for continuous monitoring it will keep pulsing the green light and is very distracting especially on reflective surfaces.

Also it is not pulling valid data. It would also be nice if there was always a “detect contact” task before it starts trying to read for heart rate.

If I took the watch off, you can still see it trying to read the heart rate. I assume this would also save a little bit of battery just validating beforehand that it is being worn and not sitting on a table.