Wyze Watch 47 Text Messages on S20

I’ve searched Google and this forum, but I can’t find a solution to my problem of not receiving text message notifications on my Samsung Galaxy S20. I get notices from all the other apps that are turned on, but none of the suggested fixes work for texts. “Messages” does not appear in the “Other Applications” list. This one of my primary uses for the watch, so not a good initial experience.

Here is a link which seems to work for others:

Notification on Watch

There are two text message selections in the Notification section of the watch. Did you try both? One is in the main Notification Screen and the other is in the Other Apps screen, as you indicated.

1 Like

Thanks for your reply.

My menus don’t look like that, but I already went through generally what the post said, and Wyze is turned on everywhere indicated. Since there is no “Messages” app under “Other Applications”, perhaps I should try a different SMS app.

1 Like

I know that my father-in-law had issues with his samsung related to messaging with other apps as did my son. They ended up installing Google Messages. That may work for you. You will also get RCS as well which Samsung seems to gave an issue with.

@R.Good , do you have any suggestions? you have a Samsung, correct?

1 Like

I installed “Google Messages”. It showed up in the “Other Applications” list. Turned that on, and I am now getting text notices on the watch. Looks like a viable solution.

Now the question is, why does “Samsung Messages” not show up?


Glad that worked for you.

Not sure why it does not show up, I will ask around the community as well. Maybe a Wyze Employee will see this thread and provide some information.

1 Like

Not a Wyze employee (as are few here, without starting their name with 'Wyze"), and not a user of Samsung. But I am a fellow ‘notifications connoisseur’, and I occasionally solve a lost notification issue with rebooting my watch. Occasionally it takes rebooting my phone.

Yes, that is an issue Wyze needs to address, Android or iOS.

Being a computer guy, one of the first things I did was restart both devices. I also cleared the cache.

@JPHaliburton did you ever find a solution?

I’m using a Samsung Galaxy S20 FE and I can’t find a message app in other applications in the watch settings at all.

I switched to Google Messages.