Wyze Video Doorbell v2 firmware - Released 4/8/2024

Here’s how to gain the beta for anyone else trying to get notifications fixed.

I had high hopes for the Beta software to fix the problem. It’s better but still not quite right. I now have installed Beta firmware
I get notifications now if I press the button TWICE in quick succession. If a single press is done, NO NOTIFICATION. I’ve repeated this several times. Reinstalled the doorbell, cycled power, reinstalled the app. It’s always the same. Requires TWO presses for me close together to get a notification.

Update: Through experimentation, I have found that the notification is coming through EVERY OTHER door bell press now. The time lag between presses does not matter. It can be 1 second or 1 minute. With this firmware, it is EVERY OTHER press of the doorbell.


Can you check if Wyze will ever provide a way for users to rollback bad firmware update in the future?

Installed the beta firmware. Turned off all filters and detection zone to see if the notifications are working.

So far so good, but will have a better idea tomorrow after it has run for a while


After installing the beta, it still didn’t fix mine. I literally walked by my doorbell a dozen times last night and was talking while spraying weeds. It never picked me up once. However, it picked up my wife leaving and returning home from the store.

I’ll submit more daily logs, assuming it helps.

Unfortunately I’m the end it did not seem to resolve much.
With my detection zone off my doorbell should detect every car that rides down the street. I had events that stopped at 5;05am EST.
When I left the house the doorbell detected me as motion and vehicle (lol).
Changing the filter on my events viewer for person there were 0 recorded in the 12 hours since I applied the patch. There should be many as we have a lot of people passing our house walking dogs out this morning going to school.

beta still didnt fix my issue. I factory reset, power cycled, did every section zone tweak imaginable. Still not events captured. The blue light flashes but nothing unless I literally put my hand over the camera lens for a moment.

Beta hasn’t fixed notifications or tagging. The mail carrier walked up to my door and rang my doorbell, then it started to record. No person detected label. I left this morning and forgot something so can back after driving off camera for about a minute, no motion or person tagged. The wind blowing my tree branches, which are out of my detection zone, has set off motion tags constantly today.

Log: 1397470

Log for today with the same issues.


Going off my previous post, can you please tell the engineers to just “to update” us back to the firmware that works? Going on almost 3 weeks without a fix. :disappointed_relieved:

1 Like

I concur. Don’t need “wide dynamic range” and ability to turn off “ding dong” at the bell……at the expense of basic functionality. Been thru 3 doorbells trying to figure out issues since April 8th firmware update improvement’s. Would be a little easier to swallow if you could get some reasonably competent live help. Everything is either a “bot” or scripted. Was told for 10 days it was something I was doing wrong, my WiFi or a bad doorbell!


Is there a technical reason the last working firmware cannot just be redeployed to all?
Then just iron out whatever the issue is with this one at a later date so we can all get our functionality back.

I agree with the other posters here. PLEASE give us back the firmware before the 04/08/24 “upgrade”. It worked flawlessly. The new and Beta firmware…I still dont get notified with any regularity of a door bell press.

If anyone from Wyze is listening…PLEASE roll back the firmware to the pre 04/08/24 release until you iron out the issues. This is getting extremely frustrating to not have basic functionality!


Today’s log 1399446


Can we get an update on this? As others have mentioned, we don’t even have basic functionality.

1 Like

Today’s log of the notifications still being broken.


It’s best to post your app log information in the topic for the current firmware in which you are using to avoid confusion. Are you using the firmware from this topic. Or the beta firmware from the other topic you posted the same information in?

1 Like

Can someone at Wyze offer any insight into what’s going on with the doorbell V2? Beta firmware isn’t fixing the issue as noted by others.


Today’s, it’s still broke log