Wyze v3 (only) Not Connecting to New Wifi

Good morning.

Bottom line: I have lots of Wyze devices. Only the Wyze v3 cameras are not connecting to the new Wifi gateway. And I have 3 of them, so its not just one. I have vacuum, filter, hvac control, floodlight, cam OG, cam pam v3, outdoor hub/cam … all of these work and connect without any issues. And also they connect without really any intervention; when I switch over the router using the same SSID/password.

Background: All three Wyze v3 cams are using latest firmware (4.36.11.8391). I’m updating my home router. Everything is the same from my previous router to the new one (minus the upgraded hardware but same manufacture; netgear). Exactly the same settings, SSID names, types of encryption, passphrase, same IP range, etc. Note, I do not share SSID names between 2.4 and 5 Ghz. Above that, I have the exact same firmware on both routers (dd-wrt); so it is exactly the same interface for each router.

So when I enable my new router, almost everything in my house associates just fine to the 2.4 and 5 Ghz networks as I use the same ssid/passphrase. I don’t have to do anything more. All my wyze devices, all my normal devices, etc.

I’ve troubleshot this numerous times with many resets (cameras and router), I got to the point where I have my new router plugged into a LAN port on my old router; turn off the radio for the old 2.4 wifi, turn on the wifi for the new 2.4 … and then monitor. Every single time, my three Wyze v3s are the ones not connecting.

I have tried to hard reset, re-associated them, etc. 2 of my cameras are in harder to reach areas, so I prefer not to do that thought I have tried with 2 cameras. And it gives me an error after scanning the qr code; having the wifi/passphrase, and then saying it cannot find the network even though it shows up.

I really don’t want to buy 3 new cam OGs when I have perfectly working Wyze v3s. I also don’t want to have my old router tethered to my new one just for three Wyze cameras either.

There has to be some known issue to help me not go crazy; and it cannot be this difficult because only Wyze v3 are having issues.

Thanks.

1 Like

Are your cameras v3 PRO? I have the exact same issue with a v3 Pro camera … tried all the same “fixes” you did and still no cigar! I do have a v3 (not PRO) that is working fine.

Do you have IPV6 enabled and WPA3? I see you indicated the settings are the same, but something to check.

If you do, disable IPV6 and switch the WPA2

1 Like

The firmware indicated by the OP (4.36.11.8391) is a V3, not V3 pro, firmware version.

1 Like

First, I respect that you are upgrading your routers. Good idea to get on new tech when possible.

You say you have a lot of Wyze. I do too. I would guess simply a lot on your network. Have you considered that you may be bumping up against the Wyze system 75 device limit?. I like to use a free tool called Fing to scan my home network and take a count. It won’t see everything with the first scan. But since its free, scan a few times. The count will tell you how close you are to the ceiling.

I have seen that WPA3 problem in other posts too, but did Wyze fix the problem with weird SSID names or passwords with bizarre characters and extended lengths?
I would assume all Wyze devices would fail if that were the case though.
Hopefully this can get figured out, because I am looking to update my main router at some point too!

The what?

Cross.larry: Its a v3 only … non-Pro. Had these since middle of 2021.

Spamoni … no to IPV6 is disabled on new and old router. Wifi security is WPA/WPA2-PSK … exactly the same as the previous router. Both using CCMP-128(AES).

Sam_Bam … thanks for the reply. I do not think I have 75. Looks like I have 43 when you count light bulbs, door sensors, home monitoring. I do have my outdoor hub and my home monitoring hub both ethernet to my router; they are both good including all these extra auxiliary devices that hand off those. Regardless, the exact same number are on my previous netgear v6700 router (with DD-WRT) that are on my new netgear v8000 (with DD-WRT). The exact same amount. And only the 3 Wyze Cam v3s are not moving over. I just tried again to tether the new router … rename the old router 2.4 GHz to mywifiold SSID and apply. then change my new router 2.4 ghz from mywifinew to mywifi. Restart the routers; and everything pops in about about 3 minutes … except those three v3 cams.

muerte33 … I completely though the same … but I’m not going with WPA3. Especially since I was using two Netgear routers; and both had been flashed to using DD-WRT firmware … so exactly the same interface. Also did a full factory reset and checked all settings on the new device. The biggest difference is the 5GHz spectrum and top in speed; plus a tri-band 5GHz on the newer one. I was also seeing a couple distance issues with my previous router with a new outdoor device that was struggling. I’d prefer not to pop the $60 on 3 new cam OGs ($19 on Amazon right now).

As a test, setup a secondary SSID and password/pass phrase on your router, just for the problem cameras. See if they can connect to a dedicated 2.4gHz network.

1 Like

WildBill … did that too.

The old 2.4 is something like SSID “Wifi24” and the 5GHz is “Wifi50”. So the old router was good on Wifi24. So I did two things (both times shutting down the original radio) … 1) created an alias 2.4 with Wifi24 SSID and didn’t work (shut that one down) and, then separately, 2) a guest network in the 2.4 range with Wifi24 SSID. Both attempts worked fine for the 10s other 2.4 Ghz devices (all other wyze devices including wyze cameras, laundry machines, garage doors openers, sprinkler systems, etc.)

I also made sure that my router was set up with the same IP range as the original; and the same subnet. I also made sure that the entire subnet was available … from x.x.x.2 to x.x.x.253 for devices to connect (so I’m not limited to 50 devices like some routers default to).

Did you try a different SSID and a simpler password?

I am having the same issue. Thankfully I only have one V3, which had been working fine until a few months ago. Last week when I finally got it back out to troubleshoot I discovered the same issue. The V3 is the only camera I have that will not connect. I have tried flashing the only 3 firmware versions available, created another network and everything else I can think of.

The error I get is “cannot connect to specific network”

Google searching makes me feel like this is a well known issue.

I have 9 cameras, 6 are v3. Three of them stopped connecting to my wifi. Any wifi at both of my connected locations. I have been told three times to add the latest firmware to a new fat32 card, and hard reset. After 6 months of fighting the “can’t connect” error I realized these three cams will not hard reset. At all. Any of my other cameras will hard reset, I can get them to “purple” light after 30 seconds. These three will never hard reset. No blue or purple lights. Just 25 seconds of recycling through a soft reboot, and repeated “ready to connect” cycles. Now what do we try if we can’t get the cameras to even do a hard reset?

@ WildBill

Its been fine for nearly 2.5 years with the same password and SSID. I did try to change one of the devices to a new SSID and password; and it gave me the same error. My app could find the 2.4 Ghz network but gave some verbal error about not able to connect to that network.

In the instance of the old router, I just reconnect and all cameras including the 3 v3s connect just fine. So its not an SSID or a password length issue; as its literally the same and all the other wyze cameras work and connect to both new router and old router (same SSID/password/encryption) just fine … except those three cam v3.