Changed from Internet provided WiFi router to a TP-Link Router - most of my Wyze equipment won't connect!

Hello all,

I hope someone can help. Yesterday, I turned off the Internet Provider’s WiFi and switched over to my own TP-Link WiFi router (Archer AX50). I am using the name SSIDs and all the other same WiFi settings.
WiFi settings:

  • 2.4 GHz
  • WPA/WPA2
  • WPA2-PSK
  • Encryption = auto (TKIP/AES)
  • Same WiFi password and SSID

Since doing so, most of my devices connected without difficulty, but the only Wyze device that successfully reconnected was my Wyze Lock Gateway/Lock.

The rest of my many Wyze products - the Sense Hub, Smart Plugs, Wyze Smart Lights, and all my cameras (v2, v3, Pan) ALL refuse to connect.

For the v3 Camera, I tried resetting the camera and going through the configuration again, but it tells me that it cannot connect to my network. Attempting to reset the Wyze Smart Plug, I follow the instructions (pre-2021), I wait a long time and then see a Connection Failed message.

What am I doing wrong? Why did this happen to ONLY most of my Wyze products?

Switching to a new WiFi router and keeping the WiFi settings should have allowed for a seamless transfer!


Your help is appreciated.

Making the new WiFi match the setting of the old WiFi is the recommendation because it should be seamless. Make double sure the settings are the same - and specifically make sure the new WiFi is NOT enabling WPA-3. The Wyze devices so far do not play nicely in a mixed WPA-2 and WPA-3 environment…

Another thing to try is to temporarily disable the 5gHz network if the SSID is shared between both frequencies.

1 Like

Thanks K6CCC, but my WiFi router doesn’t support WPA-3.

I just discovered that I can’t even connect a new (just out of box) v3 Pan camera, so that is encouraging in the sense that it’s a problem with the WiFi. I’ll post a full message in a few minutes.

Thanks WildBill. My 2.4GHz and 5GHz WiFi networks do not share the same SSID.


I just opened a brand new v3 Pan camera and I cannot connect it. I get passed the scanning of the QR code, wait a minute or so and the camera tells me that it cannot connect to my 2.4GHz WiFi network. :frowning:

This is kind of encouraging in the sense that this definitely indicates that my TP-LINK WiFi configuration is not liked by most of my Wyze devices.

The only Wyze device that continues to work is my Wyze Lock and Lock Gateway.

Here is a screen capture of my TP-Link settings for 2.4GHz. Can anyone help identify an issue?

What I have done:

  • Confirmed that there are no WiFi conflicts (SSIDs are unique for 2.4GHz, 5GHz), the previous WiFi network was shutdown.
  • Temporarily disabled the 5GHz WiFi.
  • Temporarily switched Channel width to 20MHz and Channel to 9 (to match previous WiFi settings).

I’m at a loss!

It may also be important to note that ALL my non-Wyze applications, like Kasa, etc. are all functioning normal on the 2.4GHz WiFi network.

Problem found!

When selecting the WiFi network to re-assign the Wyze devices to, for some reason, the first letter of my WiFi network was lowercase, rather than uppercase. Truly bizarre, but it was a simple solution once I understood what happened.

I don’t know why this was only a problem for the Wyze cameras and Sense (home security) because my Wyze lock and all my other non-Wyze products transitioned to the new WiFi network without issue.

Anyhow, problem solved.

Thanks to everyone for trying to help out.


Glad you found it. Yes, some devices are more picky about capitals. Devices that run some form of linux (which the Wyze cameras do) are more picky about capitals…

1 Like

Captials really are not lowercase letters or vice versa :slight_smile:

The ones that worked really shouldn’t have if that was the problem. Something else could have technically happened that escaped your notice as well unless you test it and the same thing happens. If the other devices work when its changed… they really shouldn’t. That’s not a good thing.

I have Deco XE75 Pro routers and just solved the connection issue. I have 5 Deco XE75 Pro units. I’m using Shaw Fibre+Gig with a Gateway 2 modem.

Despite having very strong wifi throughout the house, the Wyze app would struggle to connect to the cameras, and when I hit the back button, the app would typically crash.

The root cause of the problem is that Wyze cameras can’t handle a dual bandwidth network. So my primary network where my Wyze cams and other smart devices live, is now setup to be 2.4 ghz only. My guest network is now setup for both 2.4 ghz and 5 ghz. All our other devices are setup to use the guest network.

While I had turned off the Mesh function for my Wyze cams in hopes of stabilizing the situation, it’s better to leave it on so the network can move them to whatever device gives the strongest signal at the time.

I now leave Fast Roaming and Beamforming on as well.

A big thanks to DCinFL for their advice on this!

I have a TP Link router as well. Had similar issues with Wyze cameras not connecting or getting disconnected. Had to disable “smart connect” and ensure WPA2 was enabled and not WPA3 on a 2.4 network that the camera’s could find and stay with.

1 Like

I have a TriBand Linksys router (one 2.4GHz and two 5.0GHz bands). Set up new Cam Pan v3 about a week ago and no issues yet. Just 1 network with about 30 devices connected. Smart connect active… WPA2… (simultaneous tri-band)

My previous router was a TP-Link Archer A6 with a Mesh Extender. I had to disable the QOS services so that it wouldn’t keep deprioritizing my Wyze IoT and dropping them.

Smart connect is generally speaking a bad thing it’s not implementing the same way in all brands of routers, and it’s implemented really poorly in a lot of routers, but even in the routers that implemented in a better fashion, such as ASUS, I have found it to be nothing but trouble…

1 Like

Exact same thing happened to me. I switched routers with xfinity to a newer one, everything in my house connected just fine. Cannot get anything that’s a wyze product to connect. I’ve spent hours on the phone with both xfinity and wyze. No luck at all.

Wish I knew what all of that meant. I have the bands split so I have both 2.4 and 5g to choose from. Still cannot connect them.

Welcome to the Wyze User Community Forum @sheleane.steele! :raising_hand_man:

Both types of networks will have multiple bands to choose from. When you say “Split”, does that mean that each band is named (SSID) something different, each with it’s own unique password? Or, are both bands named the same, just with a 2.5GHz or 5GHz designator and only one single password?

When the new router was installed, did it get named (SSID) the exact same as the last router with the exact same password? Or, is there a new password and SSID?

if you name the wifi the same as the old one and pasword they should connect. If you change wifi name then they all need to be setup again which is a pain in the ass

Ummm. Yes. I know. Hence my questions.

There is a Wishlist request Change WiFi Network Name (SSID) and password without device reset asking for this to be changed. It could use some support and more votes.

Here is the last post: