Wyze V2 Camera Times Out When Connecting To Network


When I received my camera a few weeks ago I was able to set it up within a few minutes without any issues. However, I recently changed my WIFI password. When attempting to set the device up again I get to the part where I enter in my WIFI password using the app on my phone. The light on the camera starts flashing blue. After a few minutes it fails to connect and the camera says ,“Connection timeout”.

I made sure no special characters were in my password. I reset my phone and the camera several times but that didn’t fix the issue. I also deleted the app from my phone and reinstalled it but that didn’t help either.

Does anyone know why this is occurring and how to fix it?

1 Like

Well, often temporarily disabling mobile data on your phone can help.

Also remember the cameras only work on 2.4 GHz.

1 Like

My phone is connected to the 2.4 GHz WIFI. Also, I just tried to disable the mobile data on my phone and that didn’t work either.

1 Like

Hi @ekd823_falc3 and welcome to the Community Forum!
Looks like you’ve taken the right steps. Try powering down your camera and the internet router for 10 minutes.

When you power up the router, make sure the router is able to pass traffic before starting up the camera.
When you select the WiFi network make sure it is the 2.4Ghz (not 5).

Put in the password and confirm your phone’s spell check didn’t alter it or if you use a copy/paste, make sure it hasn’t added a space a the end of the pwd.

Hope this helps. :slightly_smiling_face:


Thanks for the information. Unfortunately this didn’t help either. I even tried changing my WIFI password to something extremely simple so I could easily type it in. I’m starting to think it might be defective. It’s so weird though because when I first received it I had no issues at all setting it up. It worked great for a few weeks. I was very pleased.

Then I decided to change my WIFI password and now it just refuses to connect. It doesn’t make sense. I contacted support and they essentially told me to do all of the things that I already have done.

1 Like

Have you checked for the latest release Firmware on the V2 & App on Android?
Try removing the App, power up reset the phone, download and reinstall App.

Yes I have done that. I was able to find out the issue. It turns out my Firewall was blocking the ports needed for the camera to connect. I asked what ports needed to be open then made the adjustments to my Firewall. After that it connected right away.

1 Like

Thanks for the update @ekd823_falc3 :+1:
Of all people, I should remember that! Had the same exact issue w/1st Wyze camera. Ended up creating a COS just for Wyze Cam & AWS.
In case anyone wants to know, here it is:

1 Like