Latest firmware for WyzeCam v2 won't connect to WiFi

After the latest firmware rolled out to my 6 WyzeCam v2 cameras, they now won’t connect to my network. They all say “This device is offline” but each of them show the proper said info for my network, and I see my router giving each camera an ip address. How can I get them back online? Thanks in advance for any suggestions

Have you tried to power cycle them?
Disconnect power for about 10 seconds, then power them back up.
Mine took a while to reconnect… Maybe 2 minutes, honestly I have no idea, but it was longer than normal.
Try it with one closest to the router…

I hard to re flash a different firmware to start the connection process again . Just the stock One , nothing else worked

Using Sdcard

Unfortunately, I’ve tried resetting all of the devices. I also force closed the app (Android), wiped cache and data, deleted the cameras from my account in the app, and then tried to re-add them. Each of the cameras won’t connect to the network. I rebooted my router too just to be sure. When I go through the setup on the phone, I get the camera to scan the QR code, and then I see it try to connect to the wifi, but it immediately times out (about 5 seconds of trying) and then says:

Connection has timed out. Please rescan QR code.

I’ve tried this several times. I have the sd cards ejected on each of the cameras too. I even did a factory reset on the camera (hold the reset button while inserting power until it starts flashing yellow). At this point, I think the only thing I can do is force an older firmware on the cameras. Does anyone have a link offhand to manually install the latest firmware?

1 Like

Well, I guess the manual installation of an older firmware won’t work either. No microsd card size, format, or boot sequence while holding down the reset button will force the camera to manually read the demo.bin file and manually flash. So far, I’ve tried exfat and Fat32. I’ve tried 2GB, 4GB, 16GB and 32GB cards, and none will make the camera go into manual firmware flash mode. I have held the button down so long on each run, that it eventually starts flashing yellow and says “ready to connect” which it’s not! Please someone tell me what I need to do to get these back in working order. I’m at a point of frustration/desperation. I have an autistic child that I use the cameras to be a second set of eyes when I can’t physically watch.

1 Like

Sorry to hear mate. But if you relied on these cams you should never use a beta version. I used a fat32 card and 8g formatted from windows.using the latest stable version. Following the step on wyze site and renaming the file. That worked for me ,I feel you pain. This release shouldn’t have come out of alpha.

Agreed, the SD card should be fat32.
Follow the flashing instructions, and then be very patient, the process can take 5 minutes.
A lot of folks have problems when they think the process is done before it really is… Like me the first time :grin:

I’m in the same boat. Updating ( (July 28, 2020)) via App didn’t work so trying upgrading firmware manually. First thought it was my Mac, so tried PC and “…hold…until the light is solid blue…” never happens. Its a constant yellow. Not sure what to try?

Hi. I just went through this and followed the manually upgrading instructions to a T, which was my problem. The Instructions say the following

Download a specific version of firmware, For Windows 10: Right-click on the folder and select extract all. For Mac: Just drag and drop the folder, put it on the root directory of your microSD card. For both Mac and Windows, rename the file to demo.bin .

I looked inside the folder and there was a file ‘demo_4.9.6.156.bin’ so got rid of the parent folder the instructions had me name demo.bin and renamed this file demo.bin on the root of the SD card and it’s working. The instructions could be a bit clearer.