Wyze Cam2 not connecting to wifi, Keep on getting the message "Connection Timed out"

I have a Wyze cam2, and not able to connect it to my new wifi router. I have done all the initial checks which I could trouble shoot, but it is still not working.

  1. Double checked the wifi password, that I’m entering on the app.
  2. Checked the router settings for MAC filtering, which is Disabled.
  3. Checked the router security and it is using WPA2.
  4. After all the above steps did not work, even did a factory reset, but still did not work.
    if anyone can help, it would be much appreciated.

Are you sure you are using 2.4ghz network?

oh yes, double checked it.

Does your ssid have anything other than letters or numbers in it?

IS this on an iOS device or Android Device? Do you have another device to test on as well?

if on an iOS you may need ti turn on Local Network in the settings. Here is my iOS Setup:

no only letters and numbers

Thank you for sharing the IOS screenshot, this device is on android and no I don’t have another Wyze cam, but have another cam from a different company, which is working fine. So not sure what’s wrong with this.

If you are interested in trying and you have the ability to, try using a phones hot spot and see if it connects to that. If it does, then it it probably something on your router which is blocking it. Or take it to a friends house and try it there to see if you can get it connected.

At this point, simply trying to eliminate items to narrow down the problem area.

Also what are you experiencing? What are the lights doing on the camera?

thank you for the idea, i did try to connect it to the mobile hotspot, but still didn’t work. I’m really not happy with the product, tried so many things and still keeps saying… “connection timed out”.

I’m facing the same issue. I have a V2 working perfectly fine. Bought a new pair and have already spent 2 full days trying to connect them. Tried everything everyone has suggested here and whatever else I could find on internet. Even contacted the support. Nothing worked. Really a shame as I had to get these imported from UK as we don’t get them in the country we are.

I needed to reinstall this camera but the QR code is not readable by my i
Patphone 7. How can I install to my router? Thanks.