Brand New Wyz Cam V3 won't connect to router

I got a new Wyze Cam V3 today and am trying to connect it. I go through all the steps to connect but it keeps saying “connection timed out”
I have an Asus RT-AC5300 router with a separate 2.4 GHz connection set up.
I have tried with three different android devices on my 2.4 GHz connection with the Wyze app installed.
I have disabled “Airtime Fairness” on the 2.4GHz as suggested here
During the last step, after scanning the QR code, on my router device list, it actually shows the Wyze Cam connected for a few seconds but then it disappears. That’s when the Cam says “connection time-out”
Here is the log of my router after the connection fails.

I have restarted my router, Unplugged the cam for 10 seconds but nothing seems to work.

I have another basic router from my service internet service provider which I am able to set it up but that isn’t the main router all of my devices connect to and the RT-AC5300 handles all my devices. I don’t want to switch to another router everytime I access my Wyze Cam.

1 Like

Do you have any other Wyze cameras on this ssid yet? Do you have any special characters in the ssid other than numbers and letters?

1 Like

The ssid has a period in it It’s called Asus 2.4. Could this be the problem?

I renamed the network to ASUS24 but still can’t connect. :disappointed:

1 Like

Have you tried it in same area as router, or are you at a distance from the router?

Try it a few feet from router, V3 cams have a slightly weaker WiFi signal than V2 cams,
When I switched from V2 to V3 cams I had to add an access point to my mesh WiFi network for a couple of cams

Thanks for the reply. I am trying the setup next to the router. Nothing…

Just making sure, but is your smartphone you are using to setup cams on the same network? 2.4Ghz?
iOS or Android ?

On your WiFi/Router can you setup static DHCP leases using the V3 cams MAC ID?

Yeah, all three devices I tried is signed into the 2.4Ghz connection when I run the setup.
I have tried to assign static Ip for the MAC Address through the DHCP server settings but the same thing happens. :thinking: :frowning_face:

Do you have the Merlin Firmware installed? I have, and don’t want to goto stock Asus firmware.

Hopefully, there will be a firmware update to fix it :crossed_fingers:

I think the dual 5ghz band is causing your issue. can you temporarily disable the 5ghz bands? being a triband router ( and one Im not familiar with) im not sure whats possible with this one. you mentioned you have a 2.4 ghz set up, but im a bit fuzzy as to what you mean by that. if the 5ghz arent fully disabled, the cam will see them and you’ll get the time out.

the Wyze cam connects to the network for a second because it connects through the phone to the SSID but when it ( the cam) tries to connect itself it goes for the 5ghz and cant so it times out. this is more than likely the issue that’s happening.

one other option is you mentioned you have another router you ARE able to set it up on. if you can set that secondary router to have the same ssid just to set the cam up on. get it working. then shut that router (router B) off the cam should connect to the ac5300 without issue as if you were using only that router. then just set that secondary up again with the old ssid.

Quick question, @canabino: Does the Merlin firmware have separate 2.4ghz and 5ghz bands?

I’m thinking of getting a new Asus router but I suspect all of them have one SSID for both bands.

The router has the abilty to seperate and setup each band individually. So I can have an SSID for each band with it’s own credentials and so on. The 2.4 GHz has an SSID of ASUS24 and the 5GHz has an SSID of ASUS5. So there is no confusion which band it connects to. On the router’s gui it shows the Wyze Cam connected to the 2.4 GHz band but then disconnects and it says “Connection timed out” on the camera during setup.

I tried this and thought it was a clever idea. It works for maybe 5 minutes after I switch off the small router and start up the AC5300, then the camera’s blue light starts flashing and the app says the camera is offline. After power cycling it the blue light keeps flashing even though the AC5300 shows it is connected to it. The app then just says thedevice is offline.


Yes, it has this option in the Merlin and stock firmware.

Is your Wireless Control Channel set to “Auto”? Try 1, 6, or 9. It’s possible that it’s selecting a too noisy channel and these channels are the most stable I’ve used.

Shouldn’t be, but you can change the ssid names, to test that possibility.

Special characters do not work for ssid names for Wyze things. See #3.

1 Like

Does your 2.4gHz Wi-Fi separate or isolate devices from each other? If so try turning that off

I have a “2.4” in one of my SSIDs and it’s not a problem.

1 Like

An Asus tri-band router simply means there are 2 5ghz bands. It’s nothing special.

If Wyze cameras connect to this 2nd router fine, just hook it up to the other router and let the Wyze cameras connect to it.

This is a temporary solution while you trouble shoot the first router.

Edit - make sure the 2nd router has a different IP subnet.

As a test setup your secondary router with an IP in your current range and its DHCP range to a different subnet. Setup 2.4 wi-fi on it and connect your phone to it, The try to add the v3’s to this new router. If they add OK then the issue is your original router or settings on it. Double check that wi-fi devices are NOT asperated from each other by the router