Cam V2 WiFi setup failing

Brand new wyze V2 cam, brand new Wyze account on new install of Android app. Phone is on a 2.4Ghz wifi (SSID not hidden) network. Everything goes through the steps as expected (entering in details for that 2.4Ghz network and scanning the QR code), but the camera never gets beyond blue light flashing, and in the app it eventually says “Connection Failed” after about a minute. Tried the process many, many times. Tried doing factory reset of the camera, power off-on, tried force closing app, tried rebooting router, and tried turning off-on the Wifi. Now the strange thing is, when I log into my router I can see that the Wyze camera has been assigned an IPv4 address (oddly no IPv6 assigned), and from my computer on that same Wifi network I can successfully ping the camera’s IPv4 address without any issue. So the camera is to some extent connected to my WiFi, but something is wrong. Any ideas?

Also, as a side note, it took me 15 tries before I could submit this post without getting an error message saying “could not tag this post.” This isn’t looking good for my continued use of Wyze…

I had the same thing happen with my first V2. I got around it by setting up a second WiFi with no security. This confirmed that my V2 was working. After that I deleted the cam and disabled the open WiFi, and set it up without any further problems. As a side note you have to have your phone on the same WiFi as the cam for setup.

Try turning off mobile data on your phone. That is usually the problem.


Thank you @shifty189 . Your comment gave me the idea to turn down my firewall security, and go through the connection process from step 1 again, and it worked. Actually the camera said “connection completed,” but the app said connection failed. So after a few reboots of app and camera the camera does now work on the app. And then I returned the firewall back to the previous settings and it still works. So obviously there’s something a bit strange that happens during the initial setup. It seems that disabling firewall should be mentioned in the troubleshooting.


What firewall?

Firewall on my router that handles LAN (WiFi) <-> WAN traffic.

I assume (for very little reason) he is talking about a Comcast modem. They have a more secure to less secure slider for there firewall. It’s worth mentioning that Comcast setting I’m talking about is labeled firewall but really has nothing to do with a firewall.

1 Like

Right. So my firewall was blocking all but the most commonly used ports on IPv4 WiFi LAN->WAN traffic, so I can only assume the camera communicates with a Wyze server on unique ports during setup. Also, the camera never requests/ obtains an IPv6 address, which is interesting.

1 Like