Setup, 'Connection timed out'

I was on a chat trying to get this Wyze cam v2 setup, and then it dropped. Seems like they’re not there now. I finally got through getting an acct etc and now the cam is blinking yellow blue. The first time, I heard “QR Code scanned…”. When tried to connect, “Connection timed out”. I did this five times with the same result. So I started over. I’m wondering why we have to put our wifi password in every time; I did it once years ago - and it always connects now. Paying meticulous attention to every step, after hearing “QR Code scanned” - five seconds later Ms Cam said “Connection timed out”. So I did it ALL again. “Connection timed out” on my phone again. What can I do now?

1 Like

Until you get it setup you’ll need to put in the password.
What is your WiFi strength? If it is marginal that may be a problem. If you have an SD card in, pull it until after setup.

1 Like

Tried it enough times and “Setup complete”! :wink:

Put in the sd card and then remembered the guy said to unug it first. Hope that didn’t screw it up.

I had the connection timed out issue and after multiple attempts, just unplugged it and reconnected and, viola! The unit connected. No sd card



Just wanted to add my recent experience to the thread … I had the same connectivity issue when trying to add a second camera. My first camera was active with no problems. Could not get the second camera to connect. Light would go from solid yellow to flashing yellow, with infrequent barely perceptible flashes of blue. It would never get past the “ready to connect” stage after accepting the QR code. I spent three days reading every forum thread and support video I could find and testing every possible scenario, with no success. The end result was that the camera itself was defective. When I ordered another camera, setup was very smooth without any delay. Just another scenario to consider when setup connectivity problems arise.

If all else fails, try this, worked for me after a firmware update bricked all my 5 Wyze Cam Pans

Had this aswell after setting up the first time. Was asked if I wanted a firmware update. Couldnt connect to the cam so I click delete device and tried to re setup but could get the cam to finish setup. (rescan qr code timeout). Flashed the oldest firmware available and everything works minus the bug updates I guess. I assume my cam is a older version physically. Hope this helps.

I know this is an old post but wanted to add my solution.

I connected my 2 v2 cams on the first try. No issues. After a few days, they both lost connection. I tried everything I could think of to reconnect them … logging out of app, deleting app, rebooting router, etc. I even turned off my 5G to ensure that only 2.4 was available. Nothing helped, always timed out while trying to connect.

Then I tried changing the firewall security from high to low. Both cameras then connected on the first try. I reset the firewall security and the cameras are both still connected.

Using aTechnicolour model CGM4140COM with Rogers.

same issue here … unable to connect … it says qr code sanned and then times out

1 Like

I am having the same issues . I also flashed the latest version of firmware but no luck. It says connection timeout , please rescan QR code.

Please help

Ran into the same problem, timing out….
Plugged and unplugged many times no success.
Fixed the problem by reentring the wifi pw even though it looked correct.
Walla the problem was solved.

Folks, I found the problem and fixed it. I am surprised no body had given detailed fix steps.

You need to install the latest firmware on these cameras if you are getting “Connection has timed out.”. To do so, go to and download the latest firmware zip file for your Wyze device on your computer. Extract the zip file. Then rename the actual file inside the extracted folder to demo.bin. Place the demo.bin file (not the folder) on the root directory of a MicroSD card that is formatted in FAT32. The card format is important here.
Unplug the camera from electrical outlet. Put this MicroSD card back in the camera. Hold the setup button and now plug the camera back to electrical power outlet while still holding the setup button. Leave the setup button after 6 seconds. Allow about 3 to 5 minutes for the camera to install this new firmware. Then click on setup button again if you want to add the camera to the Wyze app. If it is already added, then no need to do anything. You will need a laptop that has a SD card reader slot and a MicroSD card Adapter to put the MicroSD card in it and then in your laptop. Some cameras can also read from a USB drive which should also work.

1 Like

I had experienced this issue twice. Both time this happened right after a recent firmware upgrade. So the solution for me was just going to wyze’s firmware download page ( then find the previous version firmware and then install it. Here is the instruction of how to install the firmware. (
After that everything is back to working again.

Was getting a quick connection timeout rescan QR code error. Had to do a factory reset on camera. With sd card removed hold down setup for 10 second. Then v3 cam connected.