Wyze thermostat not working with Amazon Alexa

Wyze thermostat no longer works with Amazon have tried deleting the thermostat from my Alexa device and re-adding it it adds it fine then it says there was a problem.

Though its rare to occur, we have seen this problem with Wyze products in general. Probably related to the Wyze skill in Alexa. Recommend you go into Alexa on amazon.com and disable the Wyze skill. Then give it a few minutes, and re-enable it again. Give it a few minutes before you try using it.

We as a community of users have no idea the status or when there might be a mod or update to the Wyze skill (or other skills). Maybe there was a hiccup. Maybe its fixed, but could be you solve your own issue with disable/re-enable. Its a good idea to remember to do this anyway every year at least. Can’t hurt. Likely will help.

Remember Wyze has had a service disruption of late. You might still be affected.

1 Like

Thanks for the suggestion yeah I haven’t been able to control the thermostat with Alexa for a few months now so I’m not sure what the issue could be I tried as you suggested disabling and enabling the wyze skill and unfortunately still the same issue so maybe an update with the wyze skill is needed thanks.

I am experiencing this issue as well. We have two Wyze thermostats and the one downstairs continuously has issues. Right now, Alexa cannot see the temperature on that device and I tried taking it off the wall for 10 min to reset. Afterwards, I disabled the Alexa skill and re-enabled it. Neither of these resolved the issue.

1 Like