Wyze Thermostat - Alexa says it has set the temp, but temp is not actually changing

This is a strange issue… the Alexa integration with our Wyze thermostat has been working great up until recently. I’m not sure how long this has been going on because it sounds like everything is fine.

Here is the example of how I discovered the problem:

  • Temp was set low for sleeping (64)
  • Said, “Alexa, turn up the temperature”
  • I heard Alexa respond “The heat is set to 66”
  • Said again “Alexa, turn up the temperature”
  • I heard Alexa respond “The heat is set to 66”
  • after doing that a few more times, I tried saying “Alexa, set the thermostat to 70”
  • I heard Alexa respond “The heat is set to 70”

At this point I opened the “Wyze” app and noticed the temperature setting didn’t change at all (was still at 64). I noted that it was in “Home” mode, and I could SUCCESSFULLY change the set temperature with the Wyze app.

At this point, I disabled the Wyze skill in the Alexa app on my iPhone, then re-enabled it and re-detected devices.

  • same experience - Alexa says that it changed the temperature even though nothing happens.

Now I walk over to the thermostat and reboot it, by removing it from the wall and re-inserting it.

Tried everything again and it STILL won’t let Alexa change the temperature, even though Alexa thinks that it did.

What could be the problem?

Had that issue until today and it works again.

I encountered this issue today, and had already performed the same troubleshooting as you described here. Did you find a resolution?

I am having the same issue. Cannot seem to see how to resolve it.

The issue is back! Last time it was fixed and went away… Alexa will no longer set the temp!

Did you by any chance add and/or delete an Amazon Echo device when you noticed the issue begin? I reset my Echo device, so I could step my dad through setting up his new Echo device, and then began experiencing the issue.

Same issue here. Both thermostats. Alexa acknowledges, but fails to set the temp. Doing it in the Qyze app works. Something to do with the skill and integration. Not connectivity

I did not change anything, or add anything. It just stopped working.
I am pretty certain it is on Wyze or Amazon’s end…
It may seem like a small thing, but it is actually very frustrating. The way our house is setup, along with the fact that the thermostat swings the temp so far in each direction, we really need to have this working here.

I’m experiencing the same issue now…a couple of weeks ago Alexa was showing the thermostat as non-responsive, but now that issue is gone only to be replaced by the current one. Like you, I tell Alexa to set a certain temperature. She tells me “The Living Room is set to XX” but the thermostat never changes. Even when I go into the Alexa app and manually change the temperature, it reverts back to the previously set temperature after about 2 seconds. The Wyze app is functioning just as it always has and I’m able to control it through there, but I miss just being able to shout out to Alexa to do it!

Sooo literally moments away from opening a trouble ticket with Wyze this morning concerning this issue, I tested one last time, and of course now it’s working perfectly. This is after a week of failing tests daily. I don’t know if I’m more happy or frustrated at this point, but will see how this goes.

As of this morning, it appears to be working again. Maybe they fixed something…