Wyze Thermostat Install error - Extra wire

Mine was installed by Action Heating and Air in St. Augustine, FL…
You live in this area Destro?

That is pretty funny that we both went from the same original dumb thermostat, to the same smart radio thermostat, to the Wyze thermostat, what are the odds? Still couldn’t get mine to skip the error using my Android phone though.

Android as well. I wish I took a screenshot of it.

I ALSO have a Trane system and ALSO have two extra wires that are just wrapped and not used. ( black and brown )
There must be something to this …

Wake Up Be Happy

Hey neighbor, I’m in Jacksonville. Thanks for linking to the other thread which suggested reinstalling the app. I am suspicious that might be the fix since the app keeps telling me about extra wires even though it’s not wired up. Wondering if there is a step being skipped to finalize the configuration of the thermostat to get it to work correctly, and we can’t get though the wiring check to hit that step.

I’ve already invested more time than I expected this evening, so I will give reinstalling the app (and the wyze thermostat) another night.

Same here. Whoever gets back to theirs first, report results!

Success! Well, mostly. Still working on confirming it’s got heat/cool configured correctly, since those were backwards in the test. But after reinstalling the app, I opened the thermostat in the app and it started to show me the “Welcome home” screen, but popped up with an update for the thermostat to install, which I did. Afterwards, the app eventually brought me back to the home screen. To check, I removed the thermostat from the app and re-added. This time, when the “extra wires” screen showed, I was given a pop up to skip or try again. I skipped and the app asked me a few more questions before taking me to the “welcome home” screen.

I ran the system test, but it had the heating and cooling backwards, and turned the fan off during what it called heat stage 2 (which should be my electric / emergency heat). I am alarmed that it may be turning on my electric heat strip without the fan running (which could cause a fire, if safety devices are not installed and working properly). I see there is a setting under “settings / advanced” to swap heat and cool, which I had to uncheck to get it to work correctly, but I’m not sure if it’s smart enough to know what to do with my electric heat.

I will not hijack this thread with these issues, but know that reinstalling the app seems to have worked, but I’m not out-of-the-woods yet.

I tried to install mine yesterday and has similar issue. I don’t have any wires in those ports where it said I have extra wires. I uninstalled the app and also reset the thermostat by holding the knob down several times and still same issue. Also updated the firmware.

After searching for “electric heat” on the forum, I find a few other threads where this is causing quite a bit of confusion, and suspect this may be the source of the extra wire issue.

Another user said Wyze support told them to connect electric heat to * and the app would then walk them through adding electric heat.

Another thread said the heat source of energy needs to be “forced air” where I have been selecting “other”, since electric was not an option.

I am unwilling to experiment on my system with the wiring, since the system test has already yanked it around switching between cooling and heating without any delay (not real good on an older system). I tried the “forced air” setup and received mixed results, although this time it seemed to have found the electric heat, which is the only thing it might have gotten right.

I will wait to hear from Wyze support on the proper wiring AND setup.

Sounds like progress!
Definitely post back when you get it sorted and let us know what you had to do. It sounds like I’m going to have to do the exact same things as you.

I am waiting to see a response either to one of these heat pump / electric heat threads which seem to be growing daily, or to a support email I sent. I’ve since switched back to my old thermostat AGAIN. I’ll give this thermostat one more install, but after that, it’s NOT worth the hassle. This is one of the reasons I don’t miss leaving a career as an HVAC controls engineer. I don’t appreciate being a beta tester for someone I have to beg to tell me how to trick their product into being capable of 30+ year old technology. …Apologies for the rant.

1 Like

I called Wyze again today. They confirmed that you can use the wire controlling the coils as Aux → W1 or E->*

If you choose E and wire to * then you select emergency from a list of 4 items to define what it is in setup. If choose aux and wire to W1 then it becomes Stage 2. In that case you select electric heat source and forced air. In the Aux (w1) case it will be used to supplement the heat and from other post apparently kick in after a certain time if your HP isn’t cutting it. I did confirm that it will not be able to be used as emergency heat. This is ultimately what I chose. I confirmed this during testing. Stage one kicks on the heat pump outside and I get heat. Stage 2 does not kick on the heat pump and I get heat. All good.

Previously when I called Wyze I asked them about wiring emergency heat and they directed me to the * which is technically correct. That is emergency.

This time when I called them I had a much more in depth conversation. I told them that there is a lot of confusion on the forum and asked them to respond here formally. They admitted they are behind on support tickets. No surprise based on the number of inexpensive products they launched right before Christmas. Anyway, once I broke down the situation, the rep told me that I could go into W1 or * depending on how I would like to use it but ultimately we both agreed W1 makes the most sense.

Wyze did confirmed that you cannot have a single connection dual purpose as emergency and Aux. I complained and told them it would be nice if I could wire as Aux and have it supplement the heat and then override it by manually telling it to go into emergency mode and then the thermostat knows to use W1 as emergency. As long as they built the hardware correct this is only a software issue and I believe other thermostats do this. Potential future feature I guess.

Technically in an emergency you can reset the thermostat and define the wire as E, wire to * and have emergency heat. I told them having to do this would be silly and they needed to accommodate this situation as there are a lot of systems out there designed to do this as indicated by their forums.

Long story short, I wired the Aux/E wire as Aux and I satisficed with the behavior. Would like to see this dual purpose as E in the future.

Here’s my wiring I ultimately went with for those interested

Are you seeing the electric heat come on at the end of the normal heat stage 1, as mentioned in this thread:

Or have you seen temperature overshoot (which may be the same issue) as others have mentioned?

In my area of the country, the heat pump should be sufficient for heating, and the electric heat reserved for when it fails (i.e. an emergency), or the rare occurrence it gets too cold outside for the heat pump to continue functioning sufficiently (auxiliary). Most thermostats (< 30 years old) these days cover both functions. I’d say if you are used to seeing the electric heat run, try the aux function. If instead, you panic when it does run, go with the emergency function as suggested.

I appreciate the info provided, but I will wait for an official response on the proper setup. Seems like a simple task which has been overlooked.

This is primarily a user to user forum and not actively monitored by Wyze, couple that with the holidays and there is going to be little activity other than helpful users. The best way to get help from Wyze is to contact them.

WYZE Support

Live support is available:


Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT

I know they are closed Jan 1

You’re in the wrong place if you want an official statement. You have to contact support for that. This is a community forum.

1 Like

Wow. I’m having the exact same error. I cannot remove wires that aren’t there. Wyze needs to “wyze” up and pay attention to this problem because we aren’t the only ones experiencing it. I’ve asked to return my two thermostats because of this error that I cannot get past. I spent 7 hours over two days fiddling around with this, climbing up and down from the attic (Floridians know what I’m talking about). I’ve reinstalled my Honeywell thermostat, which works just fine.

I submitted a support ticket with Wyze. I submitted all the pictures of the wiring that they requested and they said it looks correct. They told me to keep hitting the “Try Again” then eventually will see the “Skip” option. Then do the function test for Heat and AC. I tried that and everything seems to be working correctly. I will monitor the system for the next couple days but it’s been half a day so far and the heat is maintaining temperature.

I received a completely different response from support. From the pictures of the old and new thermostats, they see a jumper wire between W2 and E (only on the old thermostat, there is no E on Wyze). I need to remove the jumper wire between W2 and E terminals.

I have no clue how jumpers on the old thermostat affect the Wyze thermostat, but we’ll see what support says.

I had the same experience with these phantom “extra wires” that aren’t there and could find no way to skip past this test, but only to Try Again over and over with no different result. Any surefire info on how to get this Skip popup to work would be greatly appreciated. I’m also using the android app.