Wyze thermostat [failed] in less than 2 months

Not even 2 months and the [thermostat] is completely dead. [removed-language] joke of a company.

MOD NOTE: Post edited to conform to the Community Guidelines.

So can you provide additional information as to completely dead? Did you reach out to Wyze Support? If so, can you provide the ticket number and any Log numbers you may have?

What did you do yto troubleshoot the issue?

Willing to go through a few items but would like to understand what you tried first.

Mine has been running fine as well as many others in the community. Could be a faulty T-Stat which is why you should reach out to Wyze.

4 Likes

Welcome to the Wyze User Community Forum @Patheticproduct! :raising_hand_man: Glad to have you aboard! :grin: (Just wish it was under better circumstances)

Sorry you are having Thermostat issues.

100% agree w\ @spamoni4. If it died for good, warranty replacement is in order and should be able to be handled w\ one phone call to support.

This isn’t a normal occurance for the Thermostat. Mine has been rock solid dependable for a year now with not a single reset required (knock on wood).

But if it does still have a spark of life in it, some troubleshooting of the symptoms\behavior might help get it back online.

3 Likes

What customer service? The chat that just sends you to links of videos?

Cant trouble shoot a device thats completely shot. Its dead, dead dead. Returned it this morning, will never buy a single product from this company again.

Sorry to hear that, there is a phone number to speak to someone. But since you already returned it, can’t do much now. I wish you the best in your future endeavors.

Would have loved to work through this with you as I have not had any unsolvable issues with Wyze products.

4 Likes