Wyze Switches will not pair to phone app

Bought a 3 pack of Wyze switches about 9 months ago. Finally, got chance to install two of them last week. Both switches suffer the same defect. The electrician installed both properly. They work manually to turn the lights on and off by pressing the rocker switch.

However, attempts to add the devices to Wyze Android app (fully updated) fail every time. Called technical support which was friendly but could not solve it. Here are some screenshots. Basically, we got as far as holding the phone nearby with bluetooth on to get it to recognize the device but it would not connect to it. This is before we were asked to enter the wi-fi password.
The wi-fi signal is very strong and bluetooth was fine.
Wyze supports wants an image of the label on the switch so maybe there was a bad batch. Unfortunately, the switch is in a remote location not available every day.

1 Like

Sorry to hear of your issues.

Did Wyze support have you try to factory reset the switch at all?

Couple Thoughts of things to try if Wyze Support didn’t offer any of the below;

Hard reset the device? (You would have to flip the breaker off for a few moments then power back on).

Try turning off any other Bluetooth devices connected to the phone/mobile device then adding

Try adding on a different mobile device?

And a far stretch but… who is your internet provider, and are you using that providers Wireless Router? (I had a Wireless Router, Spectrum, that would not accept the switch’s connection, then I added a new Wireless Router and the Wyze switches have worked perfectly, only reason I ask).

1 Like

I did a factory reset of the switch (hold down 30 seconds) and also turned breaker on and off. No help.
I don’t think my phone bluetooth was connected to anything else except maybe my wyze watch.

I did hook up a Wyze floodlight cam the same day and that was much further from the router than the switches, no problem there pairing it to my phone app. I don’t have another mobile device but I don’t see how this is a problem as my mobile device is paired with a number of wyze devices.

I have spectrum but use my own router. I have a Wyze switch at a different location with spectrum and it works fine.

If you have android 13 make sure the nearby devices and location permissions are enabled for Wyze. Something with them causes Bluetooth issues on android 13.

Thanks my phone is still on Android 12. I think only the newest phones have 13.

That setting is also with Android 12, it was a security update. Best to check that and make sure you allow it in the permissions

1 Like

I don’t see a setting for “nearby devices” in Android 12. Do you mean “nearby share” or “nearby connections” or maybe “NFC”
I had location activated. In the Wyze app, app permissions it has both “location” and “nearby devices” as being accessed recently.

When you long Press on the App and then go to permissions, do you not see Nearby Devices? Mine started showing with Android 12 after one of the security updates, it is there on 13 as well.

Here is what I have selected

1 Like

yes i have nearby devices on the app permissions. I just meant it was not in the settings for Android itself. This is definitely not the problem anyway as other wyze switches and lights work fine.

I had the same problem and finally had to use my tablet to finish the installation. Now all 3 work on my tablet, and phone & shared with my wife’s phone. You may want to try that if you have another device.


Can I say that this saved my insanity. I was about to box my switches are return them… I tried my phone, my wife’s phone (Mine being an LG and her’s a Motorola) and the Samsung Tablet worked with out a hitch.

1 Like

Welcome to the forum @UtahDeLorean! Saw you in the Discord server as well. Happy you have joined us on multiple platforms!

1 Like

I installed my switch today and have been having the same issue with it not connecting I even left my phone next to the switch for 30 minutes and nothing. I figured it out though and I’m here to share. Went to my list of wi-fi connections on my phone found my router that I’m connected to hit the settings button next to it. There is an option about privacy click that most phones are set to a randomized MAC address you need to use the phone’s MAC address. Try to connect again with your device using the phones Mac address. It picked up instantly and is working flawlessly.

I will give this a try next time I can. Meanwhile, maybe others can verify it works, because it was never suggested by Wyze technical support.