Smart Switch install went smooth, until it didn't. Can't connect to new switches

Greetings, all. I hope to get some insight and maybe help other, too.

I’m in the process of installing 10 Smart Switches. The first two installed just fine. I moved to another room and installed a 3rd one. The app found the switch but it won’t connect. I tried 10 times, including several hard resets, and it won’t connect. I then switched the switch with another one and it did the same thing.

Maybe the mesh system had an issue or a breaker issue. I flipped the breakers and then rebooted the modem and router. Now, my first two switches are blinking rapidly and are offline. I go back to “fix” the first two. I deleted the 1st one from the app and restarted the connection process. It also now fails to connect. On the 2nd one, I disconnected the neutral wire and reconnected it, and the came back online.

So now I’m back to the 1st and 3rd not being able to connect. I have three 3-packs of switches so I opened a new box and tried installing a 4th switch, and it also can’t connect. Then, I get a message on the app that it can’t connect to my wireless network. It named the SSID. I have a mesh network and connection speeds were tested and are fine. It’s the same mesh system since I’ve owned other Wyze cameras and plugs. It works fine and I confirmed it.

Now I have three switches installed, but none of them can connect. When I reboot one and try to connect, it brings up a radar map of the three unconnected switches. I’m guessing the closest one to the center is the switch I’m standing in front of, so I tap it and nothing. I double tap it and it brings up a screen that Bind switch Error. I press Try Again and it just sit there. I keep refreshing the screen and after about LONG minutes the screen goes totally white and non responsive.

What am I missing or doing wrong? Wyze app is updated. Firmware for all other devices are updated. Wifi is solid. Bluetooth on my phone is solid. I’m at a loss.


1 Like

I have the same issue. I tried several smart switches and could not get them to connect. I also tried in two separate locations in the house and both had the bind error. I ended up buying an Amazon Basics smart switch and it went smoothly. But I want Wyze smart switches so I can integrate them with my other smart home devices that I have with Wyze.

Does anyone have solution for this issue?