Switch won't connect

Switch is installed.
Light is blinking slowly.
Using the app, it finds the switch and says connecting and goes no further.
I have left it going for at least 40 minutes.

1 Like

Welcome to the community @marc_90277 . sorry to hear you are having issues.

I would factory reset the switch, but do not delete it from the app as it will replace what is there and your rules should stay intact.

Here is how to factory reset:


Thanks. I have reset probably 10 or 11 times so far. I have fully turned off my 5ghz network. So now only the 2.4ghz network is active. Connecting just runs never finishes.

Support cant figure it out. Very frustrating.

1 Like

Tagging @R.Good as he has had issues in the past and it turned out to be his IoT router, but not sure.

@R.Good , any ideas?

It was my router, and I spent a lot of time digging deep to try and fix it (even with Wyze Engineers) and the end result was getting a different router.

A good test, if you can, turn on your cell phone’s hotspot and connect the switch to that SSID.
If it connects and works then it is some issue with the router.

Any chance you are using Spectrum?

More about it here if interested

1 Like

That is interesting. I have Cox. I will try the hotspot!!


Too much of a headache. Just returned to home depot. What a waste of time.

1 Like

Really sucks that you had a bad experience with the Switch connecting to your network. I have a lot of the switches and they have some really great features with additional controls.

The upgrade to my IoT router was welcoming. It’s unfortunate that in some cases the Internet Service Provider routers (where I have seen most troubles) have some limiting functions with random devices at times.

Have a great day

1 Like

I’m having the exact same issue. I have 2 wyze plus that are working just fine on my router, bit the switch won’t connect. Did you find another brand that works?

I also just tried the hotspot technique. Same results.

I gave up. Went with a regular old switch type. Frustrating day and a half…

I just purchased a Legrand brand smart switch. Hopefully it gives me better luck

I installed my switch today and have been having the same issue with it not connecting I even left my phone next to the switch for 30 minutes and nothing. I figured it out though and I’m here to share. Went to my list of wi-fi connections on my phone found my router that I’m connected to hit the settings button next to it. There is an option about privacy click that most phones are set to a randomized MAC address you need to use the phone’s MAC address. Try to connect again with your device using the phones Mac address. It picked up instantly and is working flawlessly.

I was having the same problem. I was stuck on CONNECTING… but it wouldn’t connect.

I downloaded the Wyze app on my Samsung tablet and tried adding the device and it worked flawlessly. I’m not sure why I had an issue trying to set it up on my phone but I recommend trying a tablet or different device to set it up if you have issues. It might go along with our phones randomizing a mac address and the tablet didn’t randomize the mac address (my guess).


Same story as others…I set up two no problem with my Android phone, but no dice on the third. Connecting for days. After too long I tried my wife’s iphone and it connected right away. Glad it’s working, but this kind of stuff is why I won’t be installing any mission-critical wyze products yet. Thermostat, sprinkler, gun stuff, router. Maybe later.

That is basically what I ended up doing too. I still have an older phone (no cell service) that I use for other purposes. It had no problems getting through the initial setup. My LG v60, running Android OS 13 could not get past “Connecting” in the app. It did appear to connect as the switch would go from slow blinking to fast blink. Again, older phone had no issue. Now that the switch is connected to my WiFi, I have no issues controlling it from my LG v60. I’m not sure if this is a firmware bug in the light switch or incompatibility with Android OS 13 or the new Bluetooth in the v60.

I had the same issue last month. I bought a 2 pack; one worked the other did not. I contacted support, but we were unable to fix the issue. I gave up and unplugged the device. Later that day (6 hours?), I decided to try again. This time it worked without issue. Very strange!

Continuing the discussion from Switch won't connect:

I’m having the same issue with a caveat that makes me agree that this is a router issue. I have 80+ wyze devices, only 15 ( all of my switches) refuse to connect after around mid-August 2023. They WILL connect to my iphone 13’s personal hotspot with no issue, lending my to believe this is firmware issue. I’ve tried all the tricks that wyze has suggested that haven’t involved (reset, try connecting with a different device, removing device. etc. I went as far as to buy a brand new switch ( the other 15 were from the OG 11/21 release. The new one does not connect either. It gets through " Connected to Wyze cloud", “Added Device” and times out at “Finishing setup”.