Serious Wyze Switch problem

I ordered about 20 Wyze switches to use in my house, a commercial establishment, and for some elderly neighbors. I’ve installed about 5 already, which have been working fine for months.

Today, I noticed that the status indication light on one of my switches was lit, but the porch-lights powered by the light switch itself were not lit. Each time I manually pushed the switch, the indication lights toggled, and I heard a click from the switch, but the porch-lights stayed off continuously. The same thing happened when trying to use the app to turn my lights on (the display on the switch shows that it’s on, but it’s actually not). Things I’ve tried:

  1. Restarting the app. No improvement.
  2. Upgrading the firmware to the latest version. No improvement.
  3. Deleting the device from the app. It tries to connect to it but fails at every single step (sometimes “No switch found”, sometimes “Bind error”, sometimes can’t connect to wifi, etc.) Now I’m unable to add the switch back.
  4. Turning off the breaker to reset all power to the switch. Still unable to add the device.

My house has not recently had a power or wifi interruption, and it’s supposed to be smarter, and yet I am totally helpless and cannot turn my lights on when I need them. I only bought these switches because I understood that the worst that could happen was that it would revert back to a ‘dumb’ switch which I could control manually. But today I’ve realized how critical it is to only have devices that will work reliably for years controlling something as important as your lights.

Does anyone have any suggestions?

1 Like

Can you check that your not using the smart mode on the switches? They have a mode that either toggles power or toggles a diffrent smart Wyze devices on press.

Check in settings and make sure you have it set on normal mode.

1 Like

Yes, all of my switches are set to Classic Control instead of Smart Control. (Of course, this particular switch is no longer in my app, so I cannot check it.)

And this happened to all 5 switches you installed? None of them worked?

No, it happened to only 1 switch.

After some more troubleshooting, I figured out the problem. Thankfully my wife had enough common sense to suggest checking the bulbs, which I’m embarrassed to say I didn’t because there are 3 bulbs in the fixture and I didn’t think all 3 would have been bad. But sure enough, I changed out the bulbs and things are working manually. Sorry for the confusion.

I still can’t explain why I’m not able to add the device to the app after deleting the device, but I’ll keep trying. In the meantime, at least I can turn the switch on manually as needed.

Edit: I found instructions on the Wyze website on
to reset the switch by holding the button for 20 seconds. After that, I was able to add the switch back into my app.