Wyze Switch - Smart Control - no bulbs

Went to swap out a White bulb with a Color bulb. White was controlled by a switch as a Smart Device under Single Press. Added the Color bulb to Wyze, but when I go to edit the Connected Devices for the Single Press: Smart Control, none of my bulbs and lights appear.

I checked with all my other switches and no matter what their current configuration (Smart or Classic), none of the bulbs in my system appear under the Single Press: Smart Control settings. Plugs and Cameras are all there, but no lights (Bulbs or strips).

For the switches that currently control bulbs as Smart Control, they all still work. I just can’t edit any of them.

I’ve already gone through support with no luck. Everything is updated, app cache, logout/login, reinstall, try on a different device; have all be tried. I’ve deleted and re-added devices. The only thing I haven’t attempted is to create a totally new account.

The only thing I can add is that this problem has gotten progressively worse over the past couple days. As of yesterday and the day before, I was able to add lights to the Smart Control, but they didn’t appear in the list of Connected Devices on the Classic/Smart selection page. I was able to add, but not remove. Also, every time I added a bulb (or even the same bulb), it generated an additional line in the Rules history. I played around adding the same bulb over and over so that now a single press generates 70+ lines in Rules History.

Several weeks ago, a newly added switch had to be reconfigured after spontaneously forgetting it was supposed to be controlling a bulb.

Can anyone out there with a switch test this? Just go into settings for the switch and change to Smart Control. It should prompt to add a device to control. See if you have bulbs listed in that list. DON’T CHOOSE ANYTHING just in case this is a system-wide issue and you might not be able to unselect.

I checked via the beta Wyze app for Android v2.38.0 (b150) and see the same thing. Must be a bug.

1 Like

Identified in 2.38 Test Thread

1 Like

Which Wyze app version are you running?

1 Like

Thank you! :+1:

Interesting how this was reported back on 11/30, but as of yesterday and the day before, I was able to add bulbs to Smart Control. Today, they are missing. No app updates between. I’m guessing this is a server-side issue?

It’s an app bug, noted in the current beta app release and will hopefully be fixed in the next production release.

yeah, it’s not working for me either. I didn’t change anything on my end when it comes to app updates or firmware updates on devices. just suddenly gone.

I’m having this exact same issue. I tried a. Factory reset, but it did not fixed. Now, for some reason some of my Wyze plugs are also being turned on or off despite unchecking that box. I cannot add or remove smart bulbs, although the original three bulbs I had programmed in still show up and are controlled by the switch. This behavior is making the switch essentially unusable as it was installed to be hooked up to a non functional socket for the express purpose of smart control of smart bulbs only.

When is this going to be fixed?? I am starting to get frustrated with Wyze. I recently had to create a whole new account because support could not figure out how to fix issues with my account not showing all devices!

Now newly purchased switches won’t see smart bulbs. Do you guys even test before deploying updates?

Hey if you download the beta version, install an older version of the app and then you can adjust from there

I can confirm this issue also happens on iOS The problem is not limited to just Android.

Yeah, not impressed at all. Purchased replacement bulbs and a switch for kitchen and not able to use them as it disconnected and now can’t reconnect to control bulbs which was the only reason I purchased. If this was identified that long ago an immediate fix should have been provided.

How do you install an older version of the app?

1 Like

Hello all in this thread. It appears as if this issue has been resolved.


Was just circling back but @R.Good beat me to it, this issue was resolved today and the bulbs should show up again.


Yep, I was able to add bulbs to the switches. Thank you!!


Well I’ll be… I’ve been checking on this every single day since I posted this and suddenly, today, I can edit what bulbs are connected to the switch in settings. However, it doesn’t do anything for the bulbs that were previously attached. The switch still controls whatever bulbs were previously connected. Adding and removing doesn’t actually do anything with those, but I can add and remove new selections.

I need help on this. My switch still thinks it’s supposed to be controlling the original bulbs I assigned to it before this mess started. I can add and remove bulbs, but it’s still controlling 2 that are unselected. The Rules History shows 70+ commands being sent to the same bulbs over and over for a single activations. Some of them show Failed: Device Deleted harking back to the time where I removed and re-added the bulbs thinking that would fix it.