Wyze Switch getting Bind Switch Error

I have followed instructions as discussed in other bind switch errors but presists with me. I get to the connection and see Connecting then right to the Bind Switch Error on the app. When that occurs the light flashes fast for 3-5 blinks then back to the normal connectivity.

I have tried restarting phone, app and replacing with another switch but continue with the same errors.

Any advice at all would be helpful.

Thank you

1 Like

I am getting the same error on 2 switches I tried. I feel like it is a software issue. But not sure. I am using a S23 Ultra. Please let me know if you fixed it.

Seems to be on their end, ive swapped 3 diffrent switches and im getting the same error a 3 times “Bind Switch Error”. Its becoming rather annoying latley with the switches not turning things on/off, on the 1st press, or being extreamly laggy, and now this… i mean im all for struggling through rough patches but it seems to be getting worse lately, and now switch errors on newly purchased equipment…

1 Like

I am havingvthe same issue and I have tried everything. The odd bit is that it has done this before and just when I was about to bin them, they appeared to connect automatically.
I lost power long enough to reset the internet router about three weeks ago and i have not been able to get past the " Not able to Bind" screen yet again. Im just junking these crap switches and paying for a brand that works.

I have a feeling that it’s on their system and binding with my phone. Samsung s23 Ultra… I did call tech support they were not able to help. I happen to have someone here that had an older iPhone tried that and it worked… I don’t know if the 23 ultras to new of the phone and they just haven’t built it in yet… but it worked with an old iPhone to set up the switch…

I was just having the same issue. Tried eveything. Still having the bind failure on 3 new switches. This is with my Samsung Galaxy Z fold 3. Finally after giving up with my primary phone, I tried using my 14" galaxy tablet, and it worked right away for all of them. So it seems to be an app problem on some devices right now.

1 Like

I too had 3 of my many switches stop functioning to turn lights on/off after being laggy. I deleted the device and now I’m can’t add it again due to the bind error on my S23 Ultra.

It is definitely a bug in the latest version of the Wyze app. They need to FIX this!
I had an old phone with older version of the Wyze app and I was able to connect with NO problem.
I then look on my new phone and the switch is there and working.
I am using android. S22 and older moto

1 Like

Yes Wyze please push an update to the app for this ASAP!

Also having major problems with the switches lately. I have a lot of them in my house and wasn’t having any issues until recently when I’m having lag issues, double/triple/hold functions not working, and now when I’m trying to install a new switch I can’t get it to set up properly. Theses switches aren’t new and should be pretty solid now. Please roll back or fix whatever you changed on the app or platform. Lots of my stuff is pretty unusable right now

The only (fix) I have found to add a new wyze switch with a bind switch error on an android with the newest wyze version, is to use my wifes ipad to add the switch to the account. There is something about the android Bluetooth that the wyze app doesnt like when trying to install a switch. The apple wyze installed the switch first try no problem.
For refrence ive had 3 different versions of the cameras, and the wyze plugs added to the accpunt with my android without issue until i bought a switch.

Just talked to support via chat. I was told it’s a known problem and they are working on a fix. Sure hope they fix it soon.

What I did as a workaround is use my son’s IOS phone, logged into my Wyze account on his phone and was able to add the switch. I don’t want him to have control of the switch - the first time I added it using his account (I gave him access to see the doorbell cam) but there’s no way to change the ownership of the switch. So I deleted it, logged into my account on his phone and added the switch.

I sure hope they fix this soon - not being able to install them on my app on my phone is a huge issue. I’m lucky to have an IOS device to add the device.

1 Like

Yes I forgot to mention the account login and out particulars but yes that’s also what i ended up doing the only added step i preformed was to use her ipad to add it logged into my account, purely just to have all devices on one account and then share all devices with her account once everything was added to my account correctly.

I was able to use an old note 8 I had around and don’t get the error. I was able to setup some new switches with that.

1 Like

Updated play store app worked as expected S21 Android device

Pixel 6a here, while the “bind switch error” is now gone the app sits there and hangs while “connecting”. The switch’s light goes into a fast blink and after 5 minutes the “connecting” page continues to appear with no end in sight.

Same situation here with a Pixel 7. Seems like they’re making progress, but they haven’t fixed this problem yet. Real bummer.

Finally borrowed an old iPad and got this “working” but now the porch lights won’t turn on. I’ll have to check my wiring, but TBH, this might be going back to them tomorrow if I find out the wiring is fine. My patience is over on this product.

I just installed a switch and used my S23 to add it to the app - it worked fine this time. Previous attempts failed using S23 and had to use my son’s iPhone. So looks like the app issue has been fixed.

1 Like

I thought i had my wiring correct too but I switched the load and line wires… just the black ones… and mine worked.