Wyze Switch not updating firmware

For some reason the Wyze Switch is not able to update the firmware. I have tried two different switches. It connects to my router just fine and the “RouteThis” app states there is a DLS of 436.9 and a ULS 31.1. It just times out for some reason. From the iphone app I can turn the light on and off but doing anything more than that it requires a firmware update and does nothing but fail.

Welcome to the community @drrice00 .

I installed one of my switches today and was able to update it to the current Beta FW Update. So far things are working as expected. I have noted that the time it takes to actually enter the switch from the Home Menu takes a bit longer on an Android in comparison to iOS. However, using it from the Home Menu is quick from either.

Some options to try

  • I have found refreshing the power to the device and then trying to do an update corrects the issues. Is it possible to turn the Breaker off for a short bit and then turn it back on?

  • Have you tried rebooting your router so the switch establishes a fresh connection?

  • do you have another device to see if you can update from that one?

1 Like

Hello spamoni4,

Thanks for the ideas. I’m installing three switches. The first switch installed with no problems. This is the second of three that I tried. It didn’t work at first, so I swapped it with my third switch, and it didn’t work either. I did shut off the power to do the swap. I will give rebooting my router and recycle the breaker to see if that works as well. I can use my iPad to see if the update works from there as well. I think I will setup the last switch to see what happens. Maybe I just have two bad switches? But I don’t really think so. Thanks for the advice…

I am working with another Forum Member to see if he can get his switches functioning as they are supposed to. He had an issue with his Doorbell Pro as well. We are testing to see if it could be related to the iPhone. He redid his Doorbell Pro using his Android device, and it is now functioning as expected. I will let you know what happens when he tries setting up his switches via the Android as well.

Out of curiousity, what App version are you running on your iPhone?

Hello Spamoni4,

It is version 2.26.21. I connected my third switch, and it connects to my router but will not download the firmware. I still need to try my iPad. I talked to the support desk and went thru all of their tests with no success. They said there will be an update to the iOS app by the end of the week. Give it a try and see if that works.

Thanks for the help.

I have two Wyze switches installed and they connected correctly. Problem is that the additional controls I setup all of a sudden quit working. Th e switches work fine except for the additional controls. I rebooted the router with no success. will retry power down and back up to see if that works. Any help would be greatly appreciated as I have another 4 switches to install. Thanks in advance,

Hello danderso1981,

I was told to wait for the update to the Wyze app on iOS, which came out a few days ago, and try again. I did but I still have no luck updating 2 of my 3 switches firmware. As like you I can turn them off and on from the app cannot get past the firmware update. I was looking to see if maybe I need to open a port on my router. I didn’t have to for the first switch. I will give the helpdesk another call next year to see if they can provide any answers…

If anyone figures out how to fix this I’d love to know. So far I’ve had no luck at all updating the firmware for either of my wyze switches.

I just tried to update today. The iOS app has updated several times since my last post. The version I have is, 2.28.0 (a11). The switches are two at 1.2.16 and one at 1.2.19. The current version is 1.2.21. But no luck with the update. At lease with the recent iOS updates, you can set schedules on all of the switches. A few iOS versions back you could only remotely turn it on and off. If you went to the schedule, it would force you to update. That’s fine if it worked. I just haven’t had time to call support…

I had the same problem. I had a second plug and I set it up, and I was able to update the software without any problem.
I plugged the first plug back in. I reset the plug (Hold power button down for 5 seconds) and I did this 3 times. You can hear the plug switch on and off.
I then set up the plug as if it were a new plug. It notified me that there was a software upgrade and I was then able to upgrade the software without a hitch.

We are talking about the light switch, correct? You must have the magic touch. I have reset them (mine take 20 seconds to reset), turned off and on the beaker, tried them in different places and they will not update. I don’t know what kind of luck I had to update the one switch I was able to update. It won’t update to the current level either.

If you have a mobile hotspot on your phone,

Try this, it’s a bit of a pain but worked for me to get my switch updated to the new firmware.

Remove the switch from the Wyze app

Factory reset the switch (the 20 second hold you are familiar with)

Turn on mobile hotspot

Setup the switch using your mobile hotspot

Update the switch firmware

Once updated reset the switch again and add back to your home network.

I just tried mine. It updated, but mine is just outside the room with my router.