Wyze Switch & Air Purifier Beta Test 9/26/2022


Does this mean we’ll be able to turn off the LED’s while on auto or manual mode ?

I first tried updating 3 Air Purifiers using the bulk update.
All 3 failed.

I then went to reach one individually through the home tab and after starting the update I left. This time 2 were successful and 1 failed.

I then told that one to update again and this time I waited on that screen until it completed. This time it was successful.

I will now test the functionality.


How long did yours take? My AP firmware updates have been running for 35 minutes and still haven’t finished.

Edit: Updates appeared to be running but actually failed. Attempts were from the bulk update page. I went into device info > firmware version, updated from there and was back running with the latest in just a few minutes.

1 Like

I just updated two APs . It took six minutes ea.

Update 2 of 8 switches no issues

Can’t find where to control LEDs on the AP. Am I missing it? @WyzeAndy
iOS ver 2.43.1(1)
FW 1.0.12.a2
Log ID 729504


I don’t see it either. I think this is just the firmware support. We may need an app update to access the LED controls.


Agreed, I think we still need to wait for App 2.36.x before these options are actually available for the Air Purifier.

Having said that, one of them has updated the AQI every hour since the firmware update (3 dots). One of them has not updated every hour (1 dot). And the 3rd one is inconclusive (2 dots). I’ll try to check again just before midnight and again tomorrow afternoon, but so far I am thinking we need App 2.36 before these features are fully available:


Mine took more than 5 minutes. I also did it through the device and not the firmware update area

1 Like

I had to try a couple times but got it to complete update to the beta. I don’t see much difference…

1 Like

“LED display” is now showing in the device settings screen but when toggling it on or off the device does not respond

I assume this setting is for when the device is on auto or manual and we can toggle the display on or off to turn the display off . But that’s just my theory .

I’m on 1.0.10

1.0.10 is production Air Purifier firmware. This topic is for beta firmware 1.0.12.a2. The toggle LED on/off works great under both the current production and beta apps when Air Purifier beta firmware 1.0.12.a2 is loaded.

1 Like

It’s not working on my device that’s running 1.0.10.

I’m running app 2.36.0 (14)

But I see, I’m not on beta . So it won’t work on mine at all.

Any idea when this will come out with the update ?

Need beta firmware for the LED on/off to work:

Unfortunately, we don’t have access to beta>production timelines.

1 Like

Did 1.0.12.a2 beta fw get pulled? It’s not showing up.


I don’t know. I see no record of a firmware version pause on beta 1.0.12.a2 for Air Purifier. Perhaps WyzeAndy or WyzeJasonJ can look into this when Wyze returns from holiday break.

Also… did you try loading via Wyze app Home > your Air Purifier > Settings (gear icon upper right) > Device Info > Firmware Version?

Also need to ensure Air Purifier is selected in app’s list of beta devices: Wyze app Home > Account > About > Beta Program > Edit > Wyze Air Purifier (checked) > Save

Edit: removed @ callouts.


Doh. That was it. Buried under about! TIL. Thanks. Updating now.


My LED toggle is working but I’m not getting AQI trending stats in the insights page. Is this still an issue being worked on?


Yes. They said they had to delay the fix for this for app version 2.38.x


Air purifier is about two weeks old. Running beta firmware indicated in this post. It has disconnected from WiFi about 5 days in. I restarted it and it’s still disconnected. The WiFi icon constantly blinks with no resolution. I reset the device and re-added it via the Wyze app. It worked for another 5 days and it’s back to being offline and blinking WiFi icon.

Is this typical behavior or possibly a faulty unit?

Edit: Without doing any reset, I added the device back via the wizard. It seemed that it was in a discovery mode. Why?

Edit 2: Wyze is sending me a replacement unit.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.