Wyze sense Alexa integration issues?

I am running some Alexa-enabled light switches for my basement.

I had created a routine where when I walk into my basement, and Wyze sense detects motion the lights come on and when no motion is detected for 15 minutes the lights go out.

This routine has been working flawlessly for months and then sometime in the past two weeks it just quit working. Lights come on with no issues they just don’t turn off. I can manually run the routine to turn out the lights, so the routine seems to work and the switches are working.

I rebooted the camera with the sense bridge on it with no change in behavior.

I deleted the Wyze sense and readded it via my app, it seemed to work for a day or two and now it’s back to not turning off the lights.

I did a test by creating a Wyze rule to turn off an outlet switch when no movement is detected and that works just fine, while my Alexa routine did not.

I have removed the motion detector from Alexa and re-added it with no change.

So seems like something changed with the handoff to Alexa… either some code changed on the Wyze side that Alexa doesn’t register when no motion is detected, or some code changed on the Alexa side and it no longer registers when no motion is detected.

Anyone having similar issues and anyone solve this?



I started seeing the exact same thing with the same setup (Alexa routine triggers Smart Home skill WiFi switch when motion is sensed, turns off if no motion for 30 min).

As of a couple weeks the turns-off-if-no-motion routine will not fire.

I checked battery on both sensors and they’re at 3.05V. They’ve been installed for approx 4 months. I’ve ordered some new batteries but 3.05V for a 3V battery sounds “fresh” to me !

So frustrating to have to manually turn the lights off in garage and bathroom nightlight with voice commands (neither have a physical central switch).

That’s interesting… I assume you are waiting for batteries at this point?
I guess that is a possibility… however, when I look in the Wyze app, I see that the motion sensor shows “clear” and it shows clear for more than my trigger for turning the lights off.

I finally got to a point where I have a routine that makes sure the lights turn off automatically at 10:00 PM in general… then checks again at midnight just in case my youngest heads down for a beverage out of the fridge…

What’s so weird is triggering the routine when motion is detected works flawlessly… just will not trigger a routine with no motion…

And I can still turn off a Wyze outlet if there is no motion detected. so staying in the Wyze ecosystem works fine… it’s just that leap from Wyze to Alexa…

Just… so… weird…

New batteries didn’t resolve anything.

This led me to believe it was a software problem, so in the infinite wisdom of Ellen Ripley: take off, nuke it from orbit — it’s the only way too be sure.

I removed all sensors from the Wyze app and then removed the Wyze skill from within the Alexa app. I added each sensor back to the bridge, then re-enabled the Wyze skill in Alexa, and then not a single sensor would discover.

What I then found was that the sensors were still present in Alexa under device settings. Once I disabled the Wyze skill, deleted all Wyze sensors within the Alexa “device settings” interface, re-enabled the Wyze skill, all 8 sensors were discovered correctly. And then proceeded to create the motion sensor rules and now it’s all working as it was previously. I don’t know how it got out of sync but it appears to have coincided with the previous firmware update on the camera which I applied a few weeks ago right before this issue started. Jettison all the Wyze devices from Alexa and set back up and it will most likely work again.

Good luck !

1 Like

Did you manage to get your Alexa routines working again?

I’m having the same issue. I have LIFX bulbs and a Wyze motion sensor setup with Alexa routines to turn on my lights when motion is detected, and turn them off after five minutes of no motion being detected.

Since around the first week of August, the routine to turn off my lights after the motion detector is clear for five minutes stopped working. I did everything I could think of including removing all my wyze devices from alexa and removing my motion sensor from the Wyze app.

What I found is whenever I recreated the routine to turn off my lights, it would work for a few days then stop responding. So there appears to be an issue with the Wyze Alexa skill.

I can see the motion detector history in the Wyze app and it accurately shows when the motion detector detects motion and clears.

I contacted support and submitted logs multiple times and was told that their engineers would take a look at the problem. It’s been over a week since my last contact with support and nothing has been done.

If you haven’t already contacted support and are still having issues, I recommend sending over some logs and opening a support ticket. Maybe Wyze can identify and fix the problem faster if other users report that they are experiencing the same issue.

Did you try login out and back in the Alexa app and rediscover devices ?

That’s one of the first things I tried and it worked for a few days before it quit again. It’s very sporadic. Sometimes my lights will turn off after five minutes, most of the time the routine won’t fire at all.

What about your ISP ?
Do know if they are throttling your speed ?
With the stay at home order where I’m at I notice speed drops at peak usage hours…

Also if you haven’t tried it already.
Try changing your WIFi channel on the 2.4Ghz band.

1 Like

Nothing was resolved so I filled a ticket. They asked for my cameras MAC address and almost immediately after that, the routine began working again, although support didn’t mention doing anything. It stopped working about 2days later and now the “when no motion detected…” doesn’t work at all.

To everyone trying to suggest all the standard troubleshooting issues, I can tell you that the issue has to do with the Alexa - Wyze Skill integration. Enabling notifications on the sensor correctly show notices for “Sensor Clear” but the trigger never gets to Alexa. Suggesting the ISP is “throttling” or other is just stabbing in the dark randomly. If the Internet connection were an issue, the motion triggers would not fire, yet they do instantly, every time.

Something is broken with the Wyze-Alexa skill integration and it needs to be investigated and fixed. I suggest everyone dispense with troubleshooting and instead file a ticket. The more eyes they have working on it, the faster they will uncover the reason and craft a solution.



I know I’m not throttled because none of my other devices have issues, and I did a speed test which confirmed I’m getting my subscribed speeds 150/150.

I actually never noticed any speed issues on my home network, but I have noticed that LTE speeds on my phone are slower at times.

I have already checked the wifi channel of my router. There’s only one other network within range of my router.

1 Like

100% a server side issue.

Same thing happened to me after contacting support. The routine started working for two days and then stopped. Support told me that their engineers are looking into the issue, but that was last week.

I originally thought that the issue was related to the AWS maintenance that was done a few weeks ago but, the issue still persists.

1 Like

When the AWS maintenance was going on I had the issues of delayed Alexa routines going off at all different times of the night.
After hafe a day things when back to normal for me.
Prior to that I login the Wyze forum to check if anyone had the same problem with the Alexa /Wyze integration before taking things to bits.
Learned long ago that’s a no no … just the basics I described above is not often clear with some posters.

Hum I see …
If Wyze support takes to long for you.

I Know this might sound crazy but …
I’d make a new Wyze account …you need another email address.
Backup any motion videos on the cam used.
Setup just a part of your Wyze system to see if that fixes the issue.

Good luck

It’s most definitely a handoff between Wyze and Amazon.

I can set up some rules within Wyze to turn off a Wyze plug when the motion sensor shows no movement for a period of time. What is more maddening than anything is the routine with Amazon that turns on a light with motion works every time… no delays, never misses a beat… every time… turning those same lights off when the sensor clears never works anymore… I can manually run the routine and it turns out the lights…

I have disabled my Wyze skill in Alexa and removed all of my devices from Alexa… enabled the skill, logged back in and let Alexa discover my devices and set up the routines again… same experience… lights turn on but never turn off.

Guessing an API changed on the Wyze side of the house, or someone put a comma in the code that shouldn’t have been there!


So I contacted Support yesterday for the third time regarding this issue, and got a response saying they are tracking the Alexa routine issue as well as other potential bugs.

Click here if you want to read the whole email.

Thank you for checking this with us. We apologize for any inconvenience with this. This is definitely not the experience that we want you to have.

Our Technical Product team is working hard to ensure that we track and investigate these possible bug issues so we really appreciate the time and efforts you have spent running through some of these troubleshooting steps.

Thank you for your time and patience while we are working on this for you.

What’s weird is, about an hour after I received a response, my lights started turning off properly after the motion detector cleared. Hopefully this lasts longer than a few days.

IDK if they fixed the issue permanently or just did something to my account to make it work, but if you still have problems, try again to recreate the routine that turns off your device(s) and change the delay time to something around five minutes so you can easily tell if it’s working or not.

If it still fails, I guess all we can do is wait and keep sending them logs every day.

I got the same canned response and saw the same result where the routines worked right after giving them my camera info then it stopped later.

I emailed again today and they again said they are working on it but have no update. This time, no change in the routine: still not working.

Again, anyone having this trouble, please file a super ticket so they will prioritize more eyes working on it.

I’ve temporarily removed the PIR sensor and replaced it with the old zigbee PIR sensor and set back up the zigbee gateway. For the garage one, I’ve changed the routine so that it turns the light, starts a 30min delay, then shuts off the light. We’ll see how annoying it is when the garage light goes off every 30min, requiring a hand wave afterward to turn it back on.

1 Like

No resolution for me at this time. I also submitted logs and the latest request by Wyze was to verify I had the latest firmware, I was asked to unlink and relink my account with Alexa and validate the Wyze sensor is working…

I replied that I have the latest firmware, that I had unlinked my Wyze account and gone the extra step to delete my Wyze devices from the Alexa device list before signing in and doing a rediscovery.

I also create a Wyze rule to turn off a Wyze outlet when no motion is detected and that works fine, so it’s definitely the Alexa integration.

The latest response was that they will forward this over to the product team and look at the integration.

1 Like

That is odd. I just validated that mine are still not working as expected. your experience almost makes it sound like it’s an individual issue vs a global issue and that is odd.

Hope your routines keep running!

1 Like

Well, that didn’t last very long :pensive: just stopped working again. Time to recreate my routine AGAIN!!

Not sure what’s going on with you all …Alexa integration is working fine for me.
But just my opinion deleting/adding devices and resetting/setting cams might be causing the Wyze servers confusions and delays in updating all the bombardment.