Wyze scale sync - How?

I am trying to sync the Wyze Scale with my FitBit and I have authorized it so that is done. I tried closing both apps. Only closing the FitBit app.

How do I get the Scale data into my FitBit app? I am using Android but I assume this should be the same for either phone OS.


Yeah I am having same issues. I’m on a S10

I magically got this to work last night but today I cannot repeat it. [Moto G6 - Android 9]

It would be helpful if someone including a wyze person could just explain how to sync.


You should just have to open the app to the scale and be in Bluetooth range of the scale and it will sync

I believe I have been within Bluetooth (BT) range when I have tried to sync before so I will try that to see if it works. Thanks for the reply.

This is what I just did and it worked …

I opened up the wyze app and opened up the scale. Then I stood on the scale. After it registered my weight, I opened up FitBit and it synced.

I think the problem I had before was either :
that I had the FitBit app already opened
the FitBit app was closed and I opened it a while later (possibly out of BT range).

I find this to be terrible user experience. I would much prefer having a sync button in the FitBit app so that it can tell me if it cannot sync and I do not sync a weight I do not want e.g. a weight that is someone else’s or a night time weight when I want to do it in the morning for consistency. I can delete a reading so there is that solution.

Yeah. Still doesn’t update for me. Seems sus. Can’t really complain since the price was good, but I’ll just manually add it in. I’m on a Samsung S10. Wyze app open within bluetooth range, scale has bluetooth symbol on and records it within the Wyze app. Force close Fitbit app and restart it. Permissions granted and turned on for fitbit and Wyze to communicate. Nada. If I have to jump through hoops for it to sync then it really isn’t “syncing”. Manually adding takes 3 secs on the fitbit app. Was worth a shot. Oh well

I would check that the FitBit app is not running and close it if necessary [ flick it up ], then open the Wyze app and go to the scale, then weigh yourself and make sure it is registered in Wyze, then open up FitBit. I stayed near the scale as I did the above and just did it now. It did take about 30 seconds for FitBit to get my weight.

I would check your Wyze Scale settings, and that you do have FitBit as an authorized 3rd party.

Good luck

Ok great thanks. I’ll give it a shot