Fitbit App & Wyze Scale no longer syncing

I’m using a Google Pixel 2 and a new Fitbit Charge 4. I purchased the Wyze scale a few weeks back and was finally able to get the scale to sync with Fitbit. Today however, the apps are no longer syncing. Typically I have the Wyze app open and the phone nearby when I’m on the scale, and the readings then show up in fitbit. However, this morning that’s no longer the case and I can’t figure out why.

I’ve verified that the Wyze app still has permissions in Fitbit, and I also completely logged out of the Fitbit app and logged back in, but the data still doesn’t sync.

The few instructions I’ve found on line on how this is supposed to work are pretty sparse… as are any troubleshooting tips. Any advice here on what to do next?

One of the main reasons I bough this scale was for the automatic capturing of data from Wyze into Fitbit.


Hey David,

Thanks for posting & welcome to the forums!

Have you tried removing Wyze/Fitbit as a connected app and re-adding it? If not, try so and then let me know how it goes.

Let us know and welcome once again,


Hi Ken, I did, and it seems to have fixed the problem. However, yesterday’s sync brought in the prior days weight in Fitbit, while the correct weight was brought over today.

On a side note, the Fitbit app will show different date formats… As an example, last week there’s an Oct 6, 7:05am entry, then there’s a Fri 5:15pm format days later. Any idea what’s causing that?


I have same issue, it worked for months, now it is intermittent. Some days it works others it does not. I have removed and re-added the authorization several times and there is no change . Any other suggestions?

Syncing isn’t working again. I went through the process of unauthorizing then reauthorizing access again and still no-go.

This is getting very frustrating.



Bump. Having the same problem. I have unauthorized and reauthorized with no success. Also, I have completed closed out of both apps numerous times with no success. This seems to have started a couple weeks ago.

I tried to set this up yesterday, and having the same issue. Tried multiple times to close both apps, to no avail on the sync to the Fitbit app. Any help would be greatly appreciated.

Has this issue been resolved? I was thinking about pickup one of the Wyze Scales to use with my Fitbit Charge 4. If it does not sync correctly I might hold off until the issue is fixed.

It works most days for me. You have to open the wyze app and then the Fitbit app after you weigh yourself. At least that what I do. I think the issue might have been my phone but I’m not sure.

It appears to be an intermittent problem. I recently upgraded my phone from a Pixel 2 (when this problem was first noticed) to a Pixel 5. I did not transfer any data over during the upgrade, I just installed the apps as new and let them pull data from their cloud.

Fitbit syncing and showing data from the Wyze scale worked for a while, and then it didn’t, then it did again. Then Wyze upgrade their app a week+ ago, and that same day the data syncing between the 2 apps stopped. After that, syncing began again with no intervention on my part.

I decided to see if Fitbit had upgraded their app, and the last update was before the Wyze update.

I won’t be on the scale again for several days, and I have no idea if data will sych between the two apps or not.

I was able to get it to sync today for the first time. I closed both apps, weighed myself, then opened the Wyze app, waited a minute then opened the Fitbit app. Low and behold the Fitbit app, had all of the information from Wyze.

1 Like

Hello, has this been resolved. I noticed my app has not been syncing for over 6 months now. I have tried to uninstall both apps and reinstall but it still won’t sync. Currently, I am unable to unsync to fitbit app. Any suggestions?