Wyze Scale stopped syncing with Google Fit

This worked to successfully for months. I set up a new Android Pixel 4a phone a week ago and noticed that Google fit was not displaying my weight data any more. I tried clearing cache and data for both apps and even uninstalled and reinstalled Google fit and the Wyze apps. Ive ensured all apps are authorized and permissions are approved in the appropriate places. I’m at a loss.

1 Like

Have you updated the scale to the latest FW?

The scale menu says it has the latest firmware rev, 1.1.3.

I’m having the same issue. Noticed it hasn’t synced since October 11. Firmware up to date. Tried unauthorizing and reauthorization and no luck

Did you guys ever get a solution for this?

I’ve been using it for months now… At least for all of 2021 so far… And now I just noticed that it stopped syncing data from Wise to Google fit back in April.

I have checked every setting that exists in the universe and none of them help at all.



I am now having the same issue. Two days ago it just stopped syncing with Google fit. Removed authorizations and reinstated them. Made sure firmware and app were up to date. No go.

1 Like


Now this is wierd. My phone just did an update. Now Wyze is syncing with Google Fit again.

1 Like

omg, I just looked, and somehow, I haven’t been keeping up with my phone’s updates. The last entry says it failed to install the last update I applied…back in March. lol

Any chance you’d be comfortable tell me what model of phone you have?

Samsung S21

1 Like

Mine is S20.
Not that that’s anything odd…lots of peeps have these phones, but I just wanted to see if there may be any sort of connection.
So, thanks.



I mean, I know I’m an idiot, but wow.
After successfully applying the update, the problem has disappeared.

Thanks a bunch for helping me get back on track with proper phone maintenance. wow

1 Like

Has anyone figured out the fix? I’m in the same boat as others. My phone is updated to the latest security patch, the Wyze app is the latest version, the firmware to the scale says it’s up to date, and wifi and Bluetooth are working just fine.

The Wyze app hasn’t synced with Google Fit for months.

For me it was a phone update that didn’t happen. I restarted my phone and it showed up. Been syncing fine since then.

The same issue with the SCALE S & Google Fit… hasn’t worked for a month or two. Absolutely no response from WYZE support.

Same Problem stop syncing after last Phone Update on Jay 13th?

Anyone get this resolved that has the issue even with all apps and phone up to date?

I have had this same issue forever. Never worked. Both apps updated, phone updated etc. Support was totally useless.

Still no fix - still no response from support… :pensive:

So I uninstalled both apps. Then resetup it all again. Still no luck.

Then I opened the Wyze app THEN got on the scale. It showed up in Wyze as normal, but then I checked and it synched my data to Google fit. Absurd if that’s how it is supposed to work. Everytime I want to weigh myself in the morning I have to open the app first?!?! That is insane. I was under the impression that I can weigh myself and then every week or so open the Wyze app near my scale to synchronize with Wzye which should then push to Google fit.