Wyze Robot Vacuum Firmware Update

Thank you, Wyze for the firmware update today for the Robot Vacuum. You gave me exactly what I was wanting. The ability to edit the mapping and rename rooms including editing the virtual walls. I just did a run of two of my rooms and it performed perfectly. The only small drawback is the vacuum has to be cleaning to edit the virtual walls, at least that was the only way I found to do it.


I updated the app today and was unable to find the way to edit the map. Can you provide some tips?

1 Like


1 Like

App does not allow editing while it’s operating.
This is the message when you try to edit while operating:

‘Your vacuum is working now, cannot edit map’

I thought I could not split rooms because I drew a new map with the fast mapping option, but maybe this isn’t why I couldn’t divide rooms. I could combine rooms ans rename, no problem.

Can you please help me to understand how you got to the map editing options? From my device list, I picked the vacuum, then tapped the gear icon to go to settings. Here, I do not see any map editing options. Thanks for your help in advance!

Beta tester with firmware 1.6.95 on vac.

Settings - >>Map Editor

I expect you will need to be both beta and 1.6.95 for map editor.

Go into Settings and go down to Map Editor. In the editor, you can Split, Merge, and/or rename rooms. To Merge, select 2 or more rooms already showing and the Merge icon will become highlighted. Now, each time you Merge, you will have to rename the room. Do that by touching the room and touching Rename on the bottom right. To Split, select the room you want to split and touch the Split icon. A dotted line with two endpoints will appear. You manipulate them to put a “wall” where you want to split it. It is somewhat intuitive. I spent an hour or so merging and splitting rooms to match my floor plan and experiment with cleaning each room. Surprising when I chose a distant room, the vacuum passed through the rooms I did not select to get to the one I did. When done it returned to the charging station.

I am pleased with the operation now. Not so when I first received it. Good job Wyze.

1 Like

Can’t seem to get 1.6.95 on Android, stuck on 1.6.75 on beta with any possible updates applied.

The best thing about dividing up floor space into several rooms was the ability to merge most of those room back into one, after first cleaning. Lol
Really inefficient chopping up big spaces, at least when you can’t use interior walls to build rooms.
Have now divided floor space into 85% one main room and 15% 3 small rooms (with special needs) that it avoids during daily overnight cleaning cycles. So far so good, and far more efficient than when I had 9 rooms sectioned off. It cleans while we sleep. Why not just let it clean almost all of it.

Where is the fast mapping option? Is it only visible if there is no map?

I was having the same problem updating, also on the beta. I was getting a notification about the update, but when I tapped “update” I would get the “updating” screen but nothing actually happened, I must have tried 10-15 times. I eventually had to uninstall the Wyze app, leave the beta, and reinstall the app and it finally went through. Not ideal to have a problem like this for a critical update that has to be installed on short notice…

I’m glad for some form of room editing now available. Now it just needs to be tuned. I’d love the ability to snap the split room tool to interior walls, or to previously created splits. On my main floor, the openings to each room are really wide so the vacuum has a hard time differentiating most rooms. In fact the first time i ran it, there was only 1 room, and the 2nd time i ran the vacuum, it created mostly 1 room again.