Wyze Robot Vacuum Cleaning History Not Recording

Hey! I noticed recently, my vacuum isn’t saving the cleaning history anymore. I’ve run the vacuum a few times recently and the last recording in “Cleaning History” is from 4/7/23. Any ideas on how to fix this?

Welcome to the forum @blakemckee20!

I have not personally come across this and did check my history, it is still recording.

A couple of things to try if you haven’t already.

  1. Make sure you are in the latest Wyze App version.

  2. Try clearing the Wyze App Cache

  3. Power Cycle the Wyze Robot Vacuum

Let us know if any of that works.


I just checked mine. Cleaning History is also current. FW Version 1.6.306

What Firmware version is on your Vacuum?


I’ll try this. Just reset the cache and confirmed the app is up to date. I need to power cycle the vacuum next.

Hey! I’m on 1.6.306

:thinking: You haven’t had any firmware updates then. That is what it shipped with. Interesting.

I just checked for an update. No update available

1 Like

When did you buy this vacuum?

We bought the vacuum back in November.

Would you be willing to delete the vacuum from the app and set it back up as new? Your maps, history, and settings will be erased.

If your still not able to update it after that I would contact support.

I could do that. Am I not on the latest software update?

My mistake, you are on the latest version.

I would still say delete and setup the device again, I can’t think of much else to try.

Hey I deleted and setup the device again. It worked! Cleaning History is being recorded again!


Awesome, glad that did it!